<!DOCTYPE html>
<html class="prime" lang="en">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video#">
<meta charset="utf-8">
<meta content="Magic Johnson, Five For Fighting, Ted Danson, Mary Steenburgen, Robin Thicke, Bob Costas, Keith Sweat, Charlie Puth, celebrity, charity, news" lang="en" name="keywords">
<meta content="Last week, the Los Angeles Dodgers Foundation (LADF) partnered with RWQuarantunes to raise funds to provide 3.3 Million meals to the most vulnerable Angelenos impacted by COVID-19." lang="en" name="description">
<meta content="index" name="robots">
<meta content="width=device-width, initial-scale=1.0" name="viewport">
<link href="/images/apple-touch-icon-144-precomposed-1592453311.png" rel="apple-touch-icon-precomposed" sizes="144x144">
<link href="/images/apple-touch-icon-114-precomposed-1592453311.png" rel="apple-touch-icon-precomposed" sizes="114x114">
<link href="/images/apple-touch-icon-72-precomposed-1592453311.png" rel="apple-touch-icon-precomposed" sizes="72x72">
<link href="/images/apple-touch-icon-57-precomposed-1592453311.png" rel="apple-touch-icon-precomposed" sizes="57x57">
<meta content="yes" name="apple-mobile-web-app-capable">
<meta content="yes" name="mobile-web-app-capable">
<meta content="black" name="apple-mobile-web-app-status-bar-style">
<link href="/images/favicon-1592453311.png" rel="icon">
<!--[if IE]>
<link href="/images/favicon-1592453311.png" rel="shortcut icon">
<![endif]-->
<meta content="IE=edge" http-equiv="X-UA-Compatible">
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"1c91d66ab7","applicationID":"4906","transactionName":"cAsITEFbCApQFEsMVUQXOVFHUQkVGhUMDUc=","queueTime":0,"applicationTime":148,"agent":""}</script>
<script>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</script>
<meta content="/images/apple-touch-icon-144-precomposed-1592453311.png" name="msapplication-TileImage">
<meta content="#fee133" name="msapplication-TileColor">
<meta content="Look to the Stars" name="msapplication-tooltip">
<meta content="#fee133" name="msapplication-navbutton-color">
<meta content="/" name="msapplication-starturl">
<meta content="Look to the Stars" name="application-name">
<meta content="Look to the Stars" name="apple-mobile-web-app-title">
<meta content="@looktothestars" name="twitter:site">
<meta content="pk_live_idk4U6tpUXcAV1RMXtw3Rwsh" name="stripe-key">
<meta content="Look to the Stars" property="og:site_name">
<meta content="https://www.looktothestars.org/news/20084-stars-join-los-angeles-dodgers-foundation-to-raise-over-11-million-for-la-regional-food-bank" property="og:url">
<meta content="Stars Join Los Angeles Dodgers Foundation To Raise Over 1.1 Million for LA Regional Food Bank" property="og:title">
<meta content="Last week, the Los Angeles Dodgers Foundation (LADF) partnered with RWQuarantunes to raise funds to provide 3.3 Million meals to the most vulnerable Angelenos impacted by COVID-19." property="og:description">
<meta content="article" property="og:type">
<meta content="2021-02-15T12:00:00Z" property="article:published_time">
<meta content="Celebrity" property="article:tag">
<meta content="Charity" property="article:tag">
<meta content="Magic Johnson" property="article:tag">
<meta content="Five For Fighting" property="article:tag">
<meta content="Ted Danson" property="article:tag">
<meta content="Mary Steenburgen" property="article:tag">
<meta content="Robin Thicke" property="article:tag">
<meta content="Bob Costas" property="article:tag">
<meta content="Keith Sweat" property="article:tag">
<meta content="Charlie Puth" property="article:tag">
<meta content="https://www.looktothestars.org/photo/1042-ted-danson/thumbnail.jpg" property="og:image">
<meta content="Stars Join Los Angeles Dodgers Foundation To Raise Over 1.1 Million for LA Regional Food Bank" property="twitter:title">
<meta content="Last week, the Los Angeles Dodgers Foundation (LADF) partnered with RWQuarantunes to raise funds to provide 3.3 Million meals to the most vulnerable Angelenos impacted by COVID-19." property="twitter:description">
<meta content="summary" property="twitter:card">
<meta content="https://www.looktothestars.org/photo/1042-ted-danson/thumbnail.jpg" property="twitter:image">
<link href="https://www.looktothestars.org/news/20084-stars-join-los-angeles-dodgers-foundation-to-raise-over-11-million-for-la-regional-food-bank" rel="canonical">
<title>Stars Join Los Angeles Dodgers Foundation To Raise Over 1.1 Million for LA Regional Food Bank - Look to the Stars</title>
<link href="/stylesheets/all-1592453844.css" media="screen" rel="stylesheet" type="text/css" />
<script>
  var username=null;
  window._$ = function(f) { window._$.backlog.unshift(f); };
  window._$.backlog = [];
</script>

<link href="https://www.looktothestars.org/feed/rss20.xml" rel="alternate" title="Latest Celebrity Charity News Items" type="application/rss+xml" />

</head>
<body>
<nav class="navbar navbar-fixed-top navbar-inverse" role="navigation">
<div class="container-fluid">
<div class="navbar-header">
<button class="navbar-toggle" data-target=".navbar-sections-collapse" data-toggle="collapse" type="button">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a class="visible-xs visible-sm navbar-brand" href="/">
Look to the Stars
</a>
</div>
<div class="collapse navbar-collapse navbar-sections-collapse">
<ul class="nav navbar-nav hidden-sm">
<li>
<a class="hidden-sm hidden-xs" href="/">Look to the Stars</a>
</li>
</ul>
<div class="navbar-form navbar-left"><form accept-charset="UTF-8" action="https://www.looktothestars.org/search" class="search" method="get" role="search"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /></div>
<div class="form-group">
<input accesskey="s" autocomplete="off" class="form-control typeahead search-query" name="query" placeholder="Search celebs/causes" required spellcheck="off" type="search">
<input style="visibility: hidden; position: fixed;" type="submit">
</div>
</form>

</div>
<div class="navbar-left navbar-text hidden-xs hidden-sm"><div class="subscribe-buttons">
<a data-placement="bottom" data-toggle="tooltip" href="https://www.looktothestars.org/feed/rss20.xml" title="Subscribe to our feed">
<i class="fa fa-rss "></i>
<span class="sr-only">RSS feed</span>
</a>
<a class="list-subscribe-show" data-placement="bottom" data-toggle="tooltip" href="#" title="Get our news by email">
<i class="fa fa-envelope-o "></i>
<span class="sr-only">Mailing list</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://twitter.com/looktothestars" rel="nofollow" target="_new" title="Follow us on Twitter">
<i class="fa fa-twitter "></i>
<span class="sr-only">Twitter</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://www.facebook.com/pages/LookToTheStarsorg/43203819581" rel="nofollow" target="_new" title="Follow us on Facebook">
<i class="fa fa-facebook "></i>
<span class="sr-only">Facebook</span>
</a>
</div>
</div>
<ul class="nav navbar-nav navbar-right">
<li class="subscribe"><a href="/subscriptions" data-placement="bottom" data-toggle="tooltip" title="Find out about our subscriptions">Subscribe</a></li>
<li><a href="/users/sign_in">Sign in</a></li>
</ul>
<ul class="nav navbar-nav visible-sm visible-xs">
<li><a href="/celebrity" title="4636 celebrities supporting charities">Celebrities</a></li>
<li><a href="/charity" title="2389 charities with celebrity supporters">Charities</a></li>
<li><a href="/news" title="News about celebrities doing good">News</a></li>
<li><a href="/company" title="Companies with celebrity/charity interests">Companies</a></li>
<li><a href="/cause" title="Charitable areas of interest">Causes</a></li>
<li><a href="/calendar" title="Calendar of celebrity charity events">Calendar</a></li>
<li><a href="/about" title="Find out more about this website">About</a></li>

</ul>
</div>
</div>
</nav>
<div id="top"></div>
<nav class="navbar navbar-default hidden-sm hidden-xs" id="section-nav" role="navigation">
<div class="container-fluid">
<ul class="nav navbar-nav">
<li><a href="/celebrity" data-placement="bottom" data-toggle="tooltip" title="4636 celebrities supporting charities">Celebrities</a></li>
<li><a href="/charity" data-placement="bottom" data-toggle="tooltip" title="2389 charities with celebrity supporters">Charities</a></li>
<li><a href="/news" data-placement="bottom" data-toggle="tooltip" title="News about celebrities doing good">News</a></li>
<li><a href="/company" data-placement="bottom" data-toggle="tooltip" title="Companies with celebrity/charity interests">Companies</a></li>
<li><a href="/cause" data-placement="bottom" data-toggle="tooltip" title="Charitable areas of interest">Causes</a></li>
<li><a href="/calendar" data-placement="bottom" data-toggle="tooltip" title="Calendar of celebrity charity events">Calendar</a></li>
<li><a href="/about" data-placement="bottom" data-toggle="tooltip" title="Find out more about this website">About</a></li>

</ul>
</div>
</nav>
<div class="hidden-sm hidden-xs" id="masthead">
<div class="container">
<h4>
<a href="/">
<span class="sr-only">Look to the Stars - the world of celebrity giving</span>
</a>
</h4>
</div>
</div>
<div class="container" id="page" itemscope itemtype="http://schema.org/NewsArticle">
<div id="page-heading">
<ul class="breadcrumb">
<li><a href="/">Home</a></li>
<li><a href="/news">News</a></li>
</ul>
<h1 class="page-header"><span itemprop="name">Stars Join Los Angeles Dodgers Foundation To Raise Over 1.1 Million for LA Regional Food Bank</span></h1>
</div>
<div class="row">
<main class="col-md-8" id="main" role="main">
<section id="news-item">
<article>
<p class="date">
<time datetime="2021-02-15T12:00:00Z" itemprop="datePublished">February 15, 2021</time>
</p>
<div class="row">
<div class="col-md-9">
<div id="news-item-body">
<div class="teaser-photo" itemscope itemtype="http://schema.org/ImageObject">
<a href="/celebrity/ted-danson" itemprop="url"><img alt="Ted Danson: Profile" class="photo thumbnail teaser " height="150" itemprop="contentURL" src="https://www.looktothestars.org/photo/1042-ted-danson/teaser-1503164719.jpg" title="Ted Danson: Profile" width="150" /></a>
</div>

<div class="news-text" itemprop="text"><p>Last week, the Los Angeles Dodgers Foundation (<span class="caps">LADF</span>) partnered with RWQuarantunes to raise funds to provide 3.3 Million meals to the most vulnerable Angelenos impacted by <span class="caps">COVID</span>-19.</p>
<p>The star-studded virtual event, which streamed live from Dodger Stadium to more than 2,000 viewers, raised over $1.1 Million to support the Los Angeles Regional Food Bank and the foundation&#8217;s efforts to feed the hungry in Los Angeles.</p>
<p>The celebration featured appearances by the 2020 World Champion Los Angeles Dodgers, Dodger legends, and current players including Trevor Bauer, Mookie Betts, Corey Seager, Joe Kelly, Max Muncy, David Price, Will Smith, Steve Garvey, Fernando Valenzuela, Andre Ethier, and many more current and former teammates.</p>
<p>The night was packed with memorable moments, appearances and performances from musicians and actors including <a href="https://www.looktothestars.org/celebrity/ted-danson">Ted Danson</a> &amp; <a href="https://www.looktothestars.org/celebrity/mary-steenburgen">Mary Steenburgen</a>, <a href="https://www.looktothestars.org/celebrity/bob-costas">Bob Costas</a>, DJ Cassidy, Dan + Shay, Joe Esposito, Lisa Lisa, <span class="caps">SWV</span>, Shanice, En Vogue, Boys II Men, Bobby Brown, <span class="caps">TLC</span>, <a href="https://www.looktothestars.org/celebrity/keith-sweat">Keith Sweat</a>, New Edition, <a href="https://www.looktothestars.org/celebrity/five-for-fighting">Five For Fighting</a>, <a href="https://www.looktothestars.org/celebrity/charlie-puth">Charlie Puth</a>, Johnny Gill, <a href="https://www.looktothestars.org/celebrity/robin-thicke">Robin Thicke</a>, El DeBarge, Michael Fitzpatrick (Fitz and the Tantrums), Deniece Williams, Gilby Clarke, Teddy &#8216;Zig Zag&#8217; Andreadis, and Clem Burke, as well as moving tributes to Tommy Lasorda and those who have made a tremendous impact on the thousands of people in our communities who are facing food insecurity amid the pandemic.</p>
<p>Guests heard from Los Angeles Dodgers and <span class="caps">LADF</span> representatives including <span class="caps">LADF</span> <span class="caps">CEO</span> Nichol Whiteman,Manager Dave Roberts, and <a href="https://www.looktothestars.org/celebrity/magic-johnson">Magic Johnson</a>, as well as Food Bank <span class="caps">CEO</span> Michael Flood.</p>
<p>Bringing a little bit of stadium to those watching from the comfort of their own homes, the virtual event included special announcements and introductions from the voice of Dodger Stadium, Todd Leitz, and musical interludes from organist, Dieter Ruehle, who even provided the soundtrack to the evening&#8217;s seventh inning stretch.</p>
<p>&#8220;This past year was full of physical and emotional strain—testing our endurance as a global community,&#8221; said Nichol T. Whiteman, <span class="caps">CEO</span> of <span class="caps">LADF</span>. &#8220;The tremendous success of RWQuarantunes demonstrates the profound impact that we have when we merge our resources and fight for those who often live in the shadows. <span class="caps">LADF</span> appreciates each and every supporter whose generosity paves the way for Angelenos to survive these challenging times and emerge even stronger.&#8221;</p>
<p>Event chairs for the night included: Anne Globe, Blue Shield of California, Cindy Starrett &amp; Allan Bates, Elissa &amp; Matt Windisch, Eloy Mendez &amp; Scott Minerd, EquiTrust Life Insurance Company, Emily &amp; Teddy Greenspan (<span class="caps">TAG</span>-Arts), Helen &amp; Stan Kasten, Jeanie Buss &amp; the Los Angeles Lakers, John, Cathi, &amp; Alexandra Bendheim, Kennedy Wilson, LA84 Foundation, Los Angeles Aerial Rapid Transit/McCourt, Latham &amp; Watkins, Security Benefit, Stephanie &amp; Nicholas Sandler, Susan &amp; David Wolf and Covington Capital Management, and <span class="caps">UCLA</span> Health.</p>
<p>In an effort to continue supporting local businesses, <span class="caps">LADF</span> partnered with Jon &amp; Vinny&#8217;s and Osteria Mozza to deliver meals to guests who donated in advance of the evening. Dodger partners, Ketel One Vodka and Coca-Cola also provided them with premium cocktail kit deliveries. Throughout the evening, virtual attendees were invited to bid on one-of-a-kind auction items including game-used and World Series memorabilia, a White Roland Grand Piano played live on the Dodger field, and three 2020 World Series Championship rings that went for $100,000 each! The evening kicked off with a <span class="caps">VIP</span> pre-party celebration hour hosted by culinary emcee Billy Harris.</p></div>
</div>
</div>
<div class="col-md-3">
<aside id="fact-bar">
<div class="row">
<div class="col-xs-6 col-sm-8 col-md-12">
<div class="panel panel-default panel-facts">
<div class="panel-heading">
<h4>Profiles</h4>
</div>
<div class="panel-body">
<h4>Celebrities:</h4>
<ul class="item-links"><li><a href="https://www.looktothestars.org/celebrity/ted-danson">Ted Danson</a></li><li><a href="https://www.looktothestars.org/celebrity/mary-steenburgen">Mary Steenburgen</a></li><li><a href="https://www.looktothestars.org/celebrity/bob-costas">Bob Costas</a></li><li><a href="https://www.looktothestars.org/celebrity/keith-sweat">Keith Sweat</a></li><li><a href="https://www.looktothestars.org/celebrity/five-for-fighting">Five For Fighting</a></li><li><a href="https://www.looktothestars.org/celebrity/charlie-puth">Charlie Puth</a></li><li><a href="https://www.looktothestars.org/celebrity/robin-thicke">Robin Thicke</a></li><li><a href="https://www.looktothestars.org/celebrity/magic-johnson">Magic Johnson</a></li></ul>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</article>
</section>
<section id="disqus_thread"></section>
<script>
  var disqus_shortname = 'ltts';
  var disqus_identifier = 'news_item_20084';
  
  (function() {
      var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
      dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
      (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
  })();
</script>
<noscript>
Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a>
</noscript>
<a class="dsq-brlink" href="http://disqus.com">
comments powered by <span class="logo-disqus">Disqus</span>
</a>
<script type="text/javascript">
var disqus_config = function() {
  this.page.remote_auth_s3 = "e30= d2d13891b010cd0ef629c1a2d19acadafaede06e 1613392372";
  this.page.api_key = "v71HFXjyDHpgKjqXp1j1oVVUD8to60eSV7DkFgZpCGV3lYBlb33Hk1Oeh5aqEagt";
  this.sso = {
    name: "Look to the Stars",
    button: "/images/favicon-1592453311.png",
    url: "https://www.looktothestars.org/users/sign_in",
    logout: "https://www.looktothestars.org/users/sign_out",
    height: 700,
    width: 850
  };
}
</script>


<section id="related-news">
<h4>Related news stories</h4>
<section><section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/20063-nbc-oceana-debut-psa-featuring-ted-danson-calling-to-stop-plastic-pollution"><img alt="NBC, Oceana Debut PSA Featuring Ted Danson Calling To Stop Plastic Pollution" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/1042-ted-danson/teaser-1503164719.jpg" title="NBC, Oceana Debut PSA Featuring Ted Danson Calling To Stop Plastic Pollution" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/20063-nbc-oceana-debut-psa-featuring-ted-danson-calling-to-stop-plastic-pollution">NBC, Oceana Debut PSA Featuring Ted Danson Calling To Stop Plastic Pollution</a>
<span class="date">Jan 15, 2021</span>
</h4>
Today, NBC and Oceana debuted a new public service announcement (PSA) featuring actor, activist, and longtime Oceana Board Member Ted Danson asking viewers to call for policy change to ditch plastic pollution and make the world&#8217;s oceans a better place for us all.
<a href="/news/20063-nbc-oceana-debut-psa-featuring-ted-danson-calling-to-stop-plastic-pollution" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>

</section>
<section><ul class="headlines">
<li>
<h4>
<a href="https://www.looktothestars.org/news/20030-the-elizabeth-taylor-ball-to-end-aids-virtual-hosted-on-world-aids-day">The Elizabeth Taylor Ball to End AIDS: VIRTUAL Hosted on World AIDS Day</a>
<span class="date">Dec  7, 2020</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/20021-diane-warren-donates-song-to-the-dian-fossey-gorilla-funds-giving-tuesday-fundraising-campaign">Diane Warren Donates Song to the Dian Fossey Gorilla Fund's Giving Tuesday Fundraising Campaign</a>
<span class="date">Dec  1, 2020</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/20024-nautica-continues-partnership-with-oceana-via-give-change-to-make-change-round-up-program">Nautica Continues Partnership with Oceana via Give Change to Make Change Round-Up Program</a>
<span class="date">Dec  1, 2020</span>
</h4>
</li>
</ul>
</section>

</section>

<section id="related-videos">
<h4>Related videos</h4>
<div class="row">
<div class="col-md-6"><div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/1546-ted-danson-mr-mayor-oceana-psa"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="Ted Danson Mr. Mayor Oceana PSA" class="video thumb" height="67" src="https://i.vimeocdn.com/video/1035046114_1280.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/1546-ted-danson-mr-mayor-oceana-psa">Ted Danson Mr. Mayor Oceana PSA</a></h5>
</div>
</div>
<div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/1272-kids-rock-cancer-documentary"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="Kids Rock Cancer Documentary" class="video thumb" height="67" src="//i.vimeocdn.com/video/522915868_640.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/1272-kids-rock-cancer-documentary">Kids Rock Cancer Documentary</a></h5>
</div>
</div>

</div>
<div class="col-md-6"><div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/848-the-2013-global-impact-award-gala-and-dinner-honoring-sec-hillary-rodham-clinton"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="The 2013 Global Impact Award Gala and Dinner Honoring Sec. Hillary Rodham Clinton" class="video thumb" height="90" src="//i1.ytimg.com/vi/zS-vOJ7Y5ok/default.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/848-the-2013-global-impact-award-gala-and-dinner-honoring-sec-hillary-rodham-clinton">The 2013 Global Impact Award Gala and Dinner Honoring Sec. Hillary Rodham Clinton</a></h5>
</div>
</div>
<div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/549-jane-fonda-ted-danson-mary-steenburgen-eva-amurri-support-heifer-international"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="Jane Fonda, Ted Danson, Mary Steenburgen, Eva Amurri support Heifer International" class="video thumb" height="90" src="https://i2.ytimg.com/vi/iqknQrDkygk/default.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/549-jane-fonda-ted-danson-mary-steenburgen-eva-amurri-support-heifer-international">Jane Fonda, Ted Danson, Mary Steenburgen, Eva Amurri support Heifer International</a></h5>
</div>
</div>

</div>
</div>
<a href="/video" class="more">More videos <span class="arrow">&rarr;</span></a>

</section>
<section id="latest-news">
<h4><a href="/news">Latest news</a></h4>
<section><section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/20080-rodney-crowell-and-his-all-star-friends-release-songs-from-quarantine"><img alt="Rodney Crowell and His All-Star Friends Release Songs From Quarantine" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/11325-rosanne-cash/teaser-1503170158.jpg" title="Rodney Crowell and His All-Star Friends Release Songs From Quarantine" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/20080-rodney-crowell-and-his-all-star-friends-release-songs-from-quarantine">Rodney Crowell and His All-Star Friends Release Songs From Quarantine</a>
<span class="date">Feb 12, 2021</span>
</h4>
Grammy-winning artist and long-time Music Health Alliance supporter, Rodney Crowell, has enlisted a number of his all-star friends, for Songs From Quarantine, a digital compilation of rarities available for only two weeks exclusively on Bandcamp.
<a href="/news/20080-rodney-crowell-and-his-all-star-friends-release-songs-from-quarantine" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>

</section>
<section><ul class="headlines">
<li>
<h4>
<a href="https://www.looktothestars.org/news/20083-seth-macfarlane-partners-with-variety-for-valentines-concert-benefiting-mptf-and-brightfocus-foundation">Seth MacFarlane Partners with Variety for Valentine's Concert Benefiting MPTF and BrightFocus Foundation</a>
<span class="date">Feb 11, 2021</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/20079-peace-one-day-announces-the-peace-one-day-anti-racism-live-global-digital-experience">Peace One Day Announces the Peace One Day Anti-Racism Live Global Digital Experience</a>
<span class="date">Feb 11, 2021</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/20082-broadway-belts-for-pff-goes-virtual">Broadway Belts For PFF! Goes Virtual</a>
<span class="date">Feb 10, 2021</span>
</h4>
</li>
</ul>
</section>

<a href="/news" class="more">More news <span class="arrow">&rarr;</span></a>
</section>

</main>
<aside class="col-md-4 col-xs-12">
<div id="sidebar">

<section class="ad">
<div class="wrapper adsense">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2433408764489440"
     data-ad-slot="2987156042"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</section>

<section>
<h3><a href="/celebrity">Top celebrities</a></h3>
<ul class="top-thumbs">
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/elton-john" class="image-link"><img alt="Elton John" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/6341-elton-john/small_square-1503121378.jpg" title="Elton John" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/elton-john">Elton John</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/bill-clinton" class="image-link"><img alt="Bill Clinton" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/24-bill-clinton/small_square-1503121377.jpg" title="Bill Clinton" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/bill-clinton">Bill Clinton</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/sting" class="image-link"><img alt="Sting" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/134-sting/small_square-1503121378.jpg" title="Sting" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/sting">Sting</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/annie-lennox" class="image-link"><img alt="Annie Lennox" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/2984-annie-lennox/small_square-1503121378.jpg" title="Annie Lennox" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/annie-lennox">Annie Lennox</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/paul-mccartney" class="image-link"><img alt="Paul McCartney" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/7581-paul-mccartney/small_square-1503121378.jpg" title="Paul McCartney" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/paul-mccartney">Paul McCartney</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/bono" class="image-link"><img alt="Bono" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/9-bono/small_square-1503121378.jpg" title="Bono" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/bono">Bono</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/lady-gaga" class="image-link"><img alt="Lady Gaga" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/11572-lady-gaga/small_square-1503620652.jpg" title="Lady Gaga" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/lady-gaga">Lady Gaga</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/george-clooney" class="image-link"><img alt="George Clooney" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/3-george-clooney/small_square-1503121378.jpg" title="George Clooney" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/george-clooney">George Clooney</a></div>
</div>
</div>
</li>
</ul>
<a href="/celebrity" class="more">More celebrities <span class="arrow">&rarr;</span></a>
</section>
<section>
<h3><a href="/charity">Top charities</a></h3>
<ul class="top-thumbs">
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/unicef" class="image-link"><img alt="UNICEF" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/7146-unicef/small_square-1503121378.jpg" title="UNICEF" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/unicef">UNICEF</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/peta" class="image-link"><img alt="PETA" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1242-peta/small_square-1503121378.jpg" title="PETA" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/peta">PETA</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/elton-john-aids-foundation" class="image-link"><img alt="Elton John AIDS Foundation" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/6908-elton-john-aids-foundation/small_square-1503121378.jpg" title="Elton John AIDS Foundation" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/elton-john-aids-foundation">Elton John AIDS Foundation</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/red-cross" class="image-link"><img alt="Red Cross" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1295-red-cross/small_square-1503121378.jpg" title="Red Cross" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/red-cross">Red Cross</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/save-the-children" class="image-link"><img alt="Save the Children" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1251-save-the-children/small_square-1503121378.jpg" title="Save the Children" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/save-the-children">Save the Children</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/boys-and-girls-clubs-of-america" class="image-link"><img alt="Boys & Girls Clubs of America" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1259-boys-and-girls-clubs-of-america/small_square-1503129220.jpg" title="Boys & Girls Clubs of America" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/boys-and-girls-clubs-of-america">Boys & Girls Clubs of America</a></div>
</div>
</div>
</li>
</ul>
<a href="/charity" class="more">More charities <span class="arrow">&rarr;</span></a>
</section>

<section>
<h3><a href="/cause">Top causes</a></h3>
<p class="link-cloud"><span style="font-size:84%"><a href="https://www.looktothestars.org/cause/aids-and-hiv">AIDS & HIV</a></span>&emsp;
<span style="font-size:86%"><a href="https://www.looktothestars.org/cause/animals">Animals</a></span>&emsp;
<span style="font-size:99%"><a href="https://www.looktothestars.org/cause/at-risk-disadvantaged-youths">At-Risk/Disadvantaged Youths</a></span>&emsp;
<span style="font-size:90%"><a href="https://www.looktothestars.org/cause/cancer">Cancer</a></span>&emsp;
<span style="font-size:144%"><a href="https://www.looktothestars.org/cause/children">Children</a></span>&emsp;
<span style="font-size:105%"><a href="https://www.looktothestars.org/cause/education">Education</a></span>&emsp;
<span style="font-size:89%"><a href="https://www.looktothestars.org/cause/environment">Environment</a></span>&emsp;
<span style="font-size:128%"><a href="https://www.looktothestars.org/cause/health">Health</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/cause/human-rights">Human Rights</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/cause/miscellaneous">Miscellaneous</a></span>&emsp;
<span style="font-size:92%"><a href="https://www.looktothestars.org/cause/poverty">Poverty</a></span>&emsp;
<span style="font-size:85%"><a href="https://www.looktothestars.org/cause/women">Women</a></span></p>
<a href="/cause" class="more">More causes <span class="arrow">&rarr;</span></a>
</section>

<section class="ad">
<div class="wrapper adsense">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive sidebar secondary -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2433408764489440"
     data-ad-slot="4463889242"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</section>


<section class="ad">
<div class="wrapper">
<a href="/subscriptions/new"><img alt="Insider access to the industry&#x27;s most reliable celebrity/charity data" height="250" src="/images/banners/subscriptions-300x250-1592453311.jpg" width="300" /></a>
</div>
</section>

</div>
</aside>
</div>
</div>
<footer>
<div class="full">
<div class="container">
<div class="row">
<div class="col-sm-4">
<h4>About</h4>
<ul>
<li><a href="/about">About the site</a></li>
<li><a href="/about">Our team</a></li>
<li><a href="/advertising">Advertise here</a></li>
<li><a href="/contact">Contact us</a></li>
<li><a href="/subscriptions">Subscriptions</a></li>
<li><a href="/scams">Scam warning</a></li>
</ul>
</div>
<div class="col-sm-6">
<h4>Follow us</h4>
<div class="subscribe-buttons">
<a data-placement="bottom" data-toggle="tooltip" href="https://www.looktothestars.org/feed/rss20.xml" title="Subscribe to our feed">
<i class="fa fa-rss "></i>
<span class="sr-only">RSS feed</span>
</a>
<a class="list-subscribe-show" data-placement="bottom" data-toggle="tooltip" href="#" title="Get our news by email">
<i class="fa fa-envelope-o "></i>
<span class="sr-only">Mailing list</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://twitter.com/looktothestars" rel="nofollow" target="_new" title="Follow us on Twitter">
<i class="fa fa-twitter "></i>
<span class="sr-only">Twitter</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://www.facebook.com/pages/LookToTheStarsorg/43203819581" rel="nofollow" target="_new" title="Follow us on Facebook">
<i class="fa fa-facebook "></i>
<span class="sr-only">Facebook</span>
</a>
</div>

<h4>Legal</h4>
<ul>
<li><a href="/privacy">Privacy &amp; Cookie Policy</a></li>
<li><a href="/terms_of_use">Terms of Use</a></li>
<li><a href="/terms_and_conditions">Subscription Terms</a></li>
</ul>
</div>
<div class="col-sm-2">
<img alt="Footer-logo-1592453311" class="logo" src="/images/footer-logo-1592453311.svg" />
</div>
</div>
</div>
</div>
<div id="copyright">
<div class="full">
<div class="container">
Copyright &copy; 2006-2021 Look To The Stars. All rights reserved.
</div>
</div>
</div>
</footer>
<div id="tip">&nbsp;</div>
<div aria-hidden="true" aria-labelledby="list_subscription_modal_title" class="modal fade" id="list_subscription_modal" role="dialog" tabindex="-1">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-header">
<button class="close" data-dismiss="modal" type="button">
<span aria-hidden="true">&times;</span>
<span class="sr-only">Close</span>
</button>
<h3 class="modal-title" id="list_subscription_modal_title">Get our news delivered straight to your Inbox, for free!</h3>
</div>
<div class="modal-body">
<div id="list_subscriptions_form">
<form accept-charset="UTF-8" action="/list_subscriptions" class="new_list_subscription" data-remote="true" id="new_list_subscription" method="post"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /><input name="authenticity_token" type="hidden" value="fz1o+6+kxH8HiBc9GvIQWPnY71miknQNGKotOxLKQak=" /></div><div class="clearfix"></div>
<div class="form-group">
<label class="sr-only" for="list_subscription_email">Your email address:</label>
<input class="form-control" id="list_subscription_email" name="list_subscription[email]" placeholder="Your email address" required="required" size="30" type="email" />
</div>
<div class="form-group">
<input class="btn btn-primary" data-disable-with="Saving..." name="commit" type="submit" value="Subscribe now" />
<button class="btn btn-default" data-dismiss="modal" type="button">No thanks</button>
</div>
</form>

</div>

</div>
</div>
</div>
</div>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-67727-2', 'looktothestars.org');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');
</script>

<script data-main="/javascripts/all-1592453841.js" src="/javascripts/vendor/require-1592453820.js"></script>
</body>
</html>
