<!DOCTYPE html>
<html class="prime" lang="en">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video#">
<meta charset="utf-8">
<meta content="Joaquin Phoenix, Moby, Al Gore, Angélique Kidjo, Alyssa Milano, Talib Kweli, Ahmir “?uestlove” Thompson, Jane Fonda, Patricia Arquette, Jason Mraz, Rosanna Arquette, Amber Valletta, celebrity, charity, news" lang="en" name="keywords">
<meta content="Starting on April 22nd, the 50th anniversary of Earth Day, celebrities will join activists, politicians, and artists for Earth Day Live, a three-day live stream and online mobilization led by youth climate leaders." lang="en" name="description">
<meta content="index" name="robots">
<meta content="width=device-width, initial-scale=1.0" name="viewport">
<link href="/images/apple-touch-icon-144-precomposed-1587180514.png" rel="apple-touch-icon-precomposed" sizes="144x144">
<link href="/images/apple-touch-icon-114-precomposed-1587180514.png" rel="apple-touch-icon-precomposed" sizes="114x114">
<link href="/images/apple-touch-icon-72-precomposed-1587180514.png" rel="apple-touch-icon-precomposed" sizes="72x72">
<link href="/images/apple-touch-icon-57-precomposed-1587180514.png" rel="apple-touch-icon-precomposed" sizes="57x57">
<meta content="yes" name="apple-mobile-web-app-capable">
<meta content="yes" name="mobile-web-app-capable">
<meta content="black" name="apple-mobile-web-app-status-bar-style">
<link href="/images/favicon-1587180514.png" rel="icon">
<!--[if IE]>
<link href="/images/favicon-1587180514.png" rel="shortcut icon">
<![endif]-->
<meta content="IE=edge" http-equiv="X-UA-Compatible">
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"1c91d66ab7","applicationID":"4906","transactionName":"cAsITEFbCApQFEsMVUQXOVFHUQkVGhUMDUc=","queueTime":0,"applicationTime":160,"agent":""}</script>
<script>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</script>
<meta content="/images/apple-touch-icon-144-precomposed-1587180514.png" name="msapplication-TileImage">
<meta content="#fee133" name="msapplication-TileColor">
<meta content="Look to the Stars" name="msapplication-tooltip">
<meta content="#fee133" name="msapplication-navbutton-color">
<meta content="/" name="msapplication-starturl">
<meta content="Look to the Stars" name="application-name">
<meta content="Look to the Stars" name="apple-mobile-web-app-title">
<meta content="@looktothestars" name="twitter:site">
<meta content="pk_live_idk4U6tpUXcAV1RMXtw3Rwsh" name="stripe-key">
<meta content="Look to the Stars" property="og:site_name">
<meta content="https://www.looktothestars.org/news/19695-celebrities-and-musicians-join-earth-day-live-to-spur-climate-action" property="og:url">
<meta content="Celebrities and Musicians Join EARTH DAY LIVE to Spur Climate Action" property="og:title">
<meta content="Starting on April 22nd, the 50th anniversary of Earth Day, celebrities will join activists, politicians, and artists for Earth Day Live, a three-day live stream and online mobilization led by youth climate leaders." property="og:description">
<meta content="article" property="og:type">
<meta content="2020-04-21T11:30:00Z" property="article:published_time">
<meta content="Celebrity" property="article:tag">
<meta content="Charity" property="article:tag">
<meta content="Joaquin Phoenix" property="article:tag">
<meta content="Moby" property="article:tag">
<meta content="Al Gore" property="article:tag">
<meta content="Angélique Kidjo" property="article:tag">
<meta content="Alyssa Milano" property="article:tag">
<meta content="Talib Kweli" property="article:tag">
<meta content="Ahmir “?uestlove” Thompson" property="article:tag">
<meta content="Jane Fonda" property="article:tag">
<meta content="Patricia Arquette" property="article:tag">
<meta content="Jason Mraz" property="article:tag">
<meta content="Rosanna Arquette" property="article:tag">
<meta content="Amber Valletta" property="article:tag">
<meta content="https://www.looktothestars.org/photo/66-joaquin-phoenix/story_half_width.jpg" property="og:image">
<meta content="Celebrities and Musicians Join EARTH DAY LIVE to Spur Climate Action" property="twitter:title">
<meta content="Starting on April 22nd, the 50th anniversary of Earth Day, celebrities will join activists, politicians, and artists for Earth Day Live, a three-day live stream and online mobilization led by youth climate leaders." property="twitter:description">
<meta content="summary" property="twitter:card">
<meta content="https://www.looktothestars.org/photo/66-joaquin-phoenix/story_half_width.jpg" property="twitter:image">
<link href="https://www.looktothestars.org/news/19695-celebrities-and-musicians-join-earth-day-live-to-spur-climate-action" rel="canonical">
<title>Celebrities and Musicians Join EARTH DAY LIVE to Spur Climate Action - Look to the Stars</title>
<link href="/stylesheets/all-1587185614.css" media="screen" rel="stylesheet" type="text/css" />
<script>
  var username=null;
  window._$ = function(f) { window._$.backlog.unshift(f); };
  window._$.backlog = [];
</script>

<link href="https://www.looktothestars.org/feed/rss20.xml" rel="alternate" title="Latest Celebrity Charity News Items" type="application/rss+xml" />

</head>
<body>
<nav class="navbar navbar-fixed-top navbar-inverse" role="navigation">
<div class="container-fluid">
<div class="navbar-header">
<button class="navbar-toggle" data-target=".navbar-sections-collapse" data-toggle="collapse" type="button">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a class="visible-xs visible-sm navbar-brand" href="/">
Look to the Stars
</a>
</div>
<div class="collapse navbar-collapse navbar-sections-collapse">
<ul class="nav navbar-nav hidden-sm">
<li>
<a class="hidden-sm hidden-xs" href="/">Look to the Stars</a>
</li>
</ul>
<div class="navbar-form navbar-left"><form accept-charset="UTF-8" action="https://www.looktothestars.org/search" class="search" method="get" role="search"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /></div>
<div class="form-group">
<input accesskey="s" autocomplete="off" class="form-control typeahead search-query" name="query" placeholder="Search celebs/causes" required spellcheck="off" type="search">
<input style="visibility: hidden; position: fixed;" type="submit">
</div>
</form>

</div>
<div class="navbar-left navbar-text hidden-xs hidden-sm"><div class="subscribe-buttons">
<a data-placement="bottom" data-toggle="tooltip" href="https://www.looktothestars.org/feed/rss20.xml" title="Subscribe to our feed">
<i class="fa fa-rss "></i>
<span class="sr-only">RSS feed</span>
</a>
<a class="list-subscribe-show" data-placement="bottom" data-toggle="tooltip" href="#" title="Get our news by email">
<i class="fa fa-envelope-o "></i>
<span class="sr-only">Mailing list</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://twitter.com/looktothestars" rel="nofollow" target="_new" title="Follow us on Twitter">
<i class="fa fa-twitter "></i>
<span class="sr-only">Twitter</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://www.facebook.com/pages/LookToTheStarsorg/43203819581" rel="nofollow" target="_new" title="Follow us on Facebook">
<i class="fa fa-facebook "></i>
<span class="sr-only">Facebook</span>
</a>
</div>
</div>
<ul class="nav navbar-nav navbar-right">
<li class="subscribe"><a href="/subscriptions" data-placement="bottom" data-toggle="tooltip" title="Find out about our subscriptions">Subscribe</a></li>
<li><a href="/users/sign_in">Sign in</a></li>
</ul>
<ul class="nav navbar-nav visible-sm visible-xs">
<li><a href="/celebrity" title="4528 celebrities supporting charities">Celebrities</a></li>
<li><a href="/charity" title="2351 charities with celebrity supporters">Charities</a></li>
<li><a href="/news" title="News about celebrities doing good">News</a></li>
<li><a href="/company" title="Companies with celebrity/charity interests">Companies</a></li>
<li><a href="/cause" title="Charitable areas of interest">Causes</a></li>
<li><a href="/calendar" title="Calendar of celebrity charity events">Calendar</a></li>
<li><a href="/about" title="Find out more about this website">About</a></li>

</ul>
</div>
</div>
</nav>
<div id="top"></div>
<nav class="navbar navbar-default hidden-sm hidden-xs" id="section-nav" role="navigation">
<div class="container-fluid">
<ul class="nav navbar-nav">
<li><a href="/celebrity" data-placement="bottom" data-toggle="tooltip" title="4528 celebrities supporting charities">Celebrities</a></li>
<li><a href="/charity" data-placement="bottom" data-toggle="tooltip" title="2351 charities with celebrity supporters">Charities</a></li>
<li><a href="/news" data-placement="bottom" data-toggle="tooltip" title="News about celebrities doing good">News</a></li>
<li><a href="/company" data-placement="bottom" data-toggle="tooltip" title="Companies with celebrity/charity interests">Companies</a></li>
<li><a href="/cause" data-placement="bottom" data-toggle="tooltip" title="Charitable areas of interest">Causes</a></li>
<li><a href="/calendar" data-placement="bottom" data-toggle="tooltip" title="Calendar of celebrity charity events">Calendar</a></li>
<li><a href="/about" data-placement="bottom" data-toggle="tooltip" title="Find out more about this website">About</a></li>

</ul>
</div>
</nav>
<div class="hidden-sm hidden-xs" id="masthead">
<div class="container">
<h4>
<a href="/">
<span class="sr-only">Look to the Stars - the world of celebrity giving</span>
</a>
</h4>
</div>
</div>
<div class="container" id="page" itemscope itemtype="http://schema.org/NewsArticle">
<div id="page-heading">
<ul class="breadcrumb">
<li><a href="/">Home</a></li>
<li><a href="/news">News</a></li>
</ul>
<h1 class="page-header"><span itemprop="name">Celebrities and Musicians Join EARTH DAY LIVE to Spur Climate Action</span></h1>
</div>
<div class="row">
<main class="col-md-8" id="main" role="main">
<section id="news-item">
<article>
<p class="date">
<time datetime="2020-04-21T11:30:00Z" itemprop="datePublished">April 21, 2020</time>
</p>
<div class="row">
<div class="col-md-9">
<div id="news-item-body">
<div class="teaser-photo" itemscope itemtype="http://schema.org/ImageObject">
<a href="/celebrity/joaquin-phoenix" itemprop="url"><img alt="Joaquin Phoenix: Profile" class="photo thumbnail teaser " height="150" itemprop="contentURL" src="https://www.looktothestars.org/photo/66-joaquin-phoenix/teaser-1503134709.jpg" title="Joaquin Phoenix: Profile" width="150" /></a>
</div>

<div class="news-text" itemprop="text"><p>Starting on April 22nd, the 50th anniversary of Earth Day, celebrities will join activists, politicians, and artists for Earth Day Live, a three-day live stream and online mobilization led by youth climate leaders.</p>
<p>Earth Day Live will include performances and appearances from entertainers across music, TV, and film. There will be DJ sets each evening to help build community and grow the climate movement.</p>
<p>The program includes unique celebrity-activist exchanges, including a segment with communities on the frontlines of the climate crisis, hosted by actor Luke Baines and journalist Sharon Carpenter and a discussion about climate grief with New York Magazine Deputy Editor and &#8220;The Uninhabitable Earth&#8221; author David Wallace Wells and climate psychologist Margaret Klein Salamon.</p>
<p>In the midst of a global pandemic, Earth Day Live aims to spur collective action to protect our communities and our planet, through performances, conversations, and training sessions curated by climate activists.</p>
<p>Earth Day Live will be live from 9a-9p ET on April 22, 23, and 24th on <a href="https://www.earthdaylive2020.org">www.earthdaylive2020.org</a> and accessible to watch on platforms such as Facebook, YouTube, Twitter, and Twitch.</p>
<p>Scheduled programming in the live stream will include:</p>
<ul>
	<li><a href="https://www.looktothestars.org/celebrity/joaquin-phoenix">Joaquin Phoenix</a> in conversation with <a href="https://www.looktothestars.org/celebrity/moby">Moby</a>, Dr. Sweta Chakraborty, and Dr. Michael Greger about the links between <span class="caps">COVID</span>-19 &amp; Climate Emergency</li>
	<li><a href="https://www.looktothestars.org/celebrity/patricia-arquette">Patricia Arquette</a> in conversation with musician and advocate Robby Romero</li>
	<li>Conversations and panel discussions with Rev. William J. Barber II, Rev. Dr. Liz Theoharis, Bill McKibben, Mustafa Santiago Ali, David Wallace-Wells and Margaret Klein Salamon</li>
	<li>Climate activist interviews with <a href="https://www.looktothestars.org/celebrity/jane-fonda">Jane Fonda</a></li>
	<li>Musical performances by <a href="https://www.looktothestars.org/celebrity/jason-mraz">Jason Mraz</a>, <a href="https://www.looktothestars.org/celebrity/angelique-kidjo">Angélique Kidjo</a>, Emily Wells, Aimee Man &amp; Ted Leo, Nahko The Bear, and more</li>
	<li>Cooking demo with Alejandra Schrader and Dominique Crenn</li>
	<li>DJ sets with: <a href="https://www.looktothestars.org/celebrity/ahmir-questlove-thompson">Questlove</a>, <a href="https://www.looktothestars.org/celebrity/talib-kweli">Talib Kweli</a>, Beverly Bond, Madame Gandhi, and Soul Clap</li>
	<li>Talks on democracy with Erica Chenoweth and Eric Liu</li>
</ul>
<p>Scheduled cameos will include:<br />
<a href="https://www.looktothestars.org/celebrity/al-gore">Al Gore</a><br />
John Kerry<br />
Dave Burd aka lil Dicky<br />
Angela Rye<br />
Patrisse Cullors<br />
Alex MacNicoll<br />
<a href="https://www.looktothestars.org/celebrity/alyssa-milano">Alyssa Milano</a><br />
<a href="https://www.looktothestars.org/celebrity/amber-valletta">Amber Valletta</a><br />
Ilyasah Shabazz<br />
Lisa Edelstein<br />
Matt McGorry<br />
Monica Dogra<br />
Maimouna Youssef aka Mumu Fresh<br />
Ndaba Mandela<br />
<a href="https://www.looktothestars.org/celebrity/rosanna-arquette">Rosanna Arquette</a><br />
Tim Heidecker</p>
<p>Additional programming details will be released closer to the launch of Earth Day Live.</p></div>
</div>
</div>
<div class="col-md-3">
<aside id="fact-bar">
<div class="row">
<div class="col-xs-6 col-sm-8 col-md-12">
<div class="panel panel-default panel-facts">
<div class="panel-heading">
<h4>Profiles</h4>
</div>
<div class="panel-body">
<h4>Celebrities:</h4>
<ul class="item-links"><li><a href="https://www.looktothestars.org/celebrity/joaquin-phoenix">Joaquin Phoenix</a></li><li><a href="https://www.looktothestars.org/celebrity/moby">Moby</a></li><li><a href="https://www.looktothestars.org/celebrity/patricia-arquette">Patricia Arquette</a></li><li><a href="https://www.looktothestars.org/celebrity/jane-fonda">Jane Fonda</a></li><li><a href="https://www.looktothestars.org/celebrity/jason-mraz">Jason Mraz</a></li><li><a href="https://www.looktothestars.org/celebrity/angelique-kidjo">Angélique Kidjo</a></li><li><a href="https://www.looktothestars.org/celebrity/talib-kweli">Talib Kweli</a></li><li><a href="https://www.looktothestars.org/celebrity/al-gore">Al Gore</a></li><li><a href="https://www.looktothestars.org/celebrity/alyssa-milano">Alyssa Milano</a></li><li><a href="https://www.looktothestars.org/celebrity/amber-valletta">Amber Valletta</a></li><li><a href="https://www.looktothestars.org/celebrity/rosanna-arquette">Rosanna Arquette</a></li><li><a href="https://www.looktothestars.org/celebrity/ahmir-questlove-thompson">Ahmir “?uestlove” Thompson</a></li></ul>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</article>
</section>
<section id="disqus_thread"></section>
<script>
  var disqus_shortname = 'ltts';
  var disqus_identifier = 'news_item_19695';
  
  (function() {
      var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
      dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
      (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
  })();
</script>
<noscript>
Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a>
</noscript>
<a class="dsq-brlink" href="http://disqus.com">
comments powered by <span class="logo-disqus">Disqus</span>
</a>
<script type="text/javascript">
var disqus_config = function() {
  this.page.remote_auth_s3 = "e30= 7382235e87986081cedb425ea079f379f65cfd88 1587474238";
  this.page.api_key = "v71HFXjyDHpgKjqXp1j1oVVUD8to60eSV7DkFgZpCGV3lYBlb33Hk1Oeh5aqEagt";
  this.sso = {
    name: "Look to the Stars",
    button: "/images/favicon-1587180514.png",
    url: "https://www.looktothestars.org/users/sign_in",
    logout: "https://www.looktothestars.org/users/sign_out",
    height: 700,
    width: 850
  };
}
</script>


<section id="related-news">
<h4>Related news stories</h4>
<section><section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/19689-earth-day-2020-brings-together-an-unprecedented-collection-of-voices"><img alt="Earth Day 2020 Brings Together An Unprecedented Collection Of Voices" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/547-ed-begley-jr/teaser-1503125239.jpg" title="Earth Day 2020 Brings Together An Unprecedented Collection Of Voices" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/19689-earth-day-2020-brings-together-an-unprecedented-collection-of-voices">Earth Day 2020 Brings Together An Unprecedented Collection Of Voices</a>
<span class="date">Apr 17, 2020</span>
</h4>
With the 50th Anniversary of Earth Day (April 22) fast approaching, now more than ever we need to connect as a global community united in our fight to protect the health and welfare of the planet and its people.
<a href="/news/19689-earth-day-2020-brings-together-an-unprecedented-collection-of-voices" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>

</section>
<section><ul class="headlines">
<li>
<h4>
<a href="https://www.looktothestars.org/news/19667-jane-fonda-and-greenpeace-host-youth-themed-virtual-fire-drill-friday-rally">Jane Fonda and Greenpeace Host Youth-Themed Virtual Fire Drill Friday Rally</a>
<span class="date">Apr  2, 2020</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/19655-jane-fonda-and-greenpeace-launch-virtual-fire-drill-fridays">Jane Fonda and Greenpeace Launch Virtual Fire Drill Fridays</a>
<span class="date">Mar 26, 2020</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/19629-stars-appear-in-3rd-annual-pomellato-for-women-video">Stars Appear In 3rd Annual Pomellato For Women Video</a>
<span class="date">Mar  9, 2020</span>
</h4>
</li>
</ul>
</section>

</section>

<section id="related-videos">
<h4>Related videos</h4>
<div class="row">
<div class="col-md-6"><div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/1492-defythename-a-psa-by-monica-lewinsky"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="#DefyTheName | A PSA by Monica Lewinsky" class="video thumb" height="90" src="https://i.ytimg.com/vi/eykBgEtuYmg/default.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/1492-defythename-a-psa-by-monica-lewinsky">#DefyTheName | A PSA by Monica Lewinsky</a></h5>
</div>
</div>
<div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/1355-the-reluctant-entertainers"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="The Reluctant Entertainers" class="video thumb" height="90" src="https://i.ytimg.com/vi/CnZ14krFTag/default.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/1355-the-reluctant-entertainers">The Reluctant Entertainers</a></h5>
</div>
</div>

</div>
<div class="col-md-6"><div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/1263-stop-the-hate-49-celebrities-honor-49-victims-of-orlando-tragedy-in-ryan-murphy-produced-tribute"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="Stop the Hate: 49 Celebrities Honor 49 Victims of Orlando Tragedy in Ryan Murphy-Produced Tribute" class="video thumb" height="90" src="https://i.ytimg.com/vi/Nq6xRZlCSoM/default.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/1263-stop-the-hate-49-celebrities-honor-49-victims-of-orlando-tragedy-in-ryan-murphy-produced-tribute">Stop the Hate: 49 Celebrities Honor 49 Victims of Orlando Tragedy in Ryan Murphy-Produced Tribute</a></h5>
</div>
</div>
<div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/1258-animal-wellness-psa"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="ANIMAL WELLNESS PSA" class="video thumb" height="67" src="//i.vimeocdn.com/video/575899164_1280.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/1258-animal-wellness-psa">ANIMAL WELLNESS PSA</a></h5>
</div>
</div>

</div>
</div>
<a href="/video" class="more">More videos <span class="arrow">&rarr;</span></a>

</section>
<section id="latest-news">
<h4><a href="/news">Latest news</a></h4>
<section><section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/19680-ice-cube-to-create-t-shirts-and-donate-proceeds-to-hospitals-fighting-coronavirus"><img alt="Ice Cube To Create T-Shirts And Donate Proceeds To Hospitals Fighting Coronavirus" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/13329-check-yo-self-before-you-wreck-yo-self/teaser-1586725440.jpg" title="Ice Cube To Create T-Shirts And Donate Proceeds To Hospitals Fighting Coronavirus" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/19680-ice-cube-to-create-t-shirts-and-donate-proceeds-to-hospitals-fighting-coronavirus">Ice Cube To Create T-Shirts And Donate Proceeds To Hospitals Fighting Coronavirus</a>
<span class="date">Apr 20, 2020</span>
</h4>
As the country and world continue to come together to fight against COVID-19, Ice Cube announced today the creation of special &#8220;Check Yo Self Before You Wreck Yo Self&#8221; t-shirts utilizing his famous lyrics as a perfect microcosm for how we all need to act – nobody is immune and we all need to protect each other.
<a href="/news/19680-ice-cube-to-create-t-shirts-and-donate-proceeds-to-hospitals-fighting-coronavirus" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>

</section>
<section><ul class="headlines">
<li>
<h4>
<a href="https://www.looktothestars.org/news/19691-one-world-together-at-home-announced-127-million-in-commitments-to-date">One World: Together At Home Announced $127 Million In Commitments To Date</a>
<span class="date">Apr 20, 2020</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/19688-filmmaker-and-celebrated-actors-with-disabilities-team-with-easterseals">Filmmaker and Celebrated Actors with Disabilities Team with Easterseals</a>
<span class="date">Apr 20, 2020</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/19689-earth-day-2020-brings-together-an-unprecedented-collection-of-voices">Earth Day 2020 Brings Together An Unprecedented Collection Of Voices</a>
<span class="date">Apr 17, 2020</span>
</h4>
</li>
</ul>
</section>

<a href="/news" class="more">More news <span class="arrow">&rarr;</span></a>
</section>

</main>
<aside class="col-md-4 col-xs-12">
<div id="sidebar">

<section class="ad">
<div class="wrapper adsense">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2433408764489440"
     data-ad-slot="2987156042"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</section>

<section>
<h3><a href="/celebrity">Top celebrities</a></h3>
<ul class="top-thumbs">
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/elton-john" class="image-link"><img alt="Elton John" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/6341-elton-john/small_square-1503121378.jpg" title="Elton John" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/elton-john">Elton John</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/bill-clinton" class="image-link"><img alt="Bill Clinton" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/24-bill-clinton/small_square-1503121377.jpg" title="Bill Clinton" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/bill-clinton">Bill Clinton</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/annie-lennox" class="image-link"><img alt="Annie Lennox" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/2984-annie-lennox/small_square-1503121378.jpg" title="Annie Lennox" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/annie-lennox">Annie Lennox</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/paul-mccartney" class="image-link"><img alt="Paul McCartney" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/7581-paul-mccartney/small_square-1503121378.jpg" title="Paul McCartney" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/paul-mccartney">Paul McCartney</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/bono" class="image-link"><img alt="Bono" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/9-bono/small_square-1503121378.jpg" title="Bono" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/bono">Bono</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/sting" class="image-link"><img alt="Sting" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/134-sting/small_square-1503121378.jpg" title="Sting" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/sting">Sting</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/lady-gaga" class="image-link"><img alt="Lady Gaga" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/11572-lady-gaga/small_square-1503620652.jpg" title="Lady Gaga" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/lady-gaga">Lady Gaga</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/ellen-degeneres" class="image-link"><img alt="Ellen DeGeneres" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/373-ellen-degeneres/small_square-1503121378.jpg" title="Ellen DeGeneres" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/ellen-degeneres">Ellen DeGeneres</a></div>
</div>
</div>
</li>
</ul>
<a href="/celebrity" class="more">More celebrities <span class="arrow">&rarr;</span></a>
</section>
<section>
<h3><a href="/charity">Top charities</a></h3>
<ul class="top-thumbs">
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/unicef" class="image-link"><img alt="UNICEF" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/7146-unicef/small_square-1503121378.jpg" title="UNICEF" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/unicef">UNICEF</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/peta" class="image-link"><img alt="PETA" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1242-peta/small_square-1503121378.jpg" title="PETA" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/peta">PETA</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/red-cross" class="image-link"><img alt="Red Cross" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1295-red-cross/small_square-1503121378.jpg" title="Red Cross" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/red-cross">Red Cross</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/elton-john-aids-foundation" class="image-link"><img alt="Elton John AIDS Foundation" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/6908-elton-john-aids-foundation/small_square-1503121378.jpg" title="Elton John AIDS Foundation" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/elton-john-aids-foundation">Elton John AIDS Foundation</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/save-the-children" class="image-link"><img alt="Save the Children" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1251-save-the-children/small_square-1503121378.jpg" title="Save the Children" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/save-the-children">Save the Children</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/make-a-wish-foundation" class="image-link"><img alt="Make-A-Wish Foundation" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/3051-make-a-wish-foundation/small_square-1503121378.jpg" title="Make-A-Wish Foundation" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/make-a-wish-foundation">Make-A-Wish Foundation</a></div>
</div>
</div>
</li>
</ul>
<a href="/charity" class="more">More charities <span class="arrow">&rarr;</span></a>
</section>

<section>
<h3><a href="/cause">Top causes</a></h3>
<p class="link-cloud"><span style="font-size:84%"><a href="https://www.looktothestars.org/cause/aids-and-hiv">AIDS & HIV</a></span>&emsp;
<span style="font-size:86%"><a href="https://www.looktothestars.org/cause/animals">Animals</a></span>&emsp;
<span style="font-size:99%"><a href="https://www.looktothestars.org/cause/at-risk-disadvantaged-youths">At-Risk/Disadvantaged Youths</a></span>&emsp;
<span style="font-size:90%"><a href="https://www.looktothestars.org/cause/cancer">Cancer</a></span>&emsp;
<span style="font-size:144%"><a href="https://www.looktothestars.org/cause/children">Children</a></span>&emsp;
<span style="font-size:105%"><a href="https://www.looktothestars.org/cause/education">Education</a></span>&emsp;
<span style="font-size:89%"><a href="https://www.looktothestars.org/cause/environment">Environment</a></span>&emsp;
<span style="font-size:127%"><a href="https://www.looktothestars.org/cause/health">Health</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/cause/human-rights">Human Rights</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/cause/miscellaneous">Miscellaneous</a></span>&emsp;
<span style="font-size:92%"><a href="https://www.looktothestars.org/cause/poverty">Poverty</a></span>&emsp;
<span style="font-size:85%"><a href="https://www.looktothestars.org/cause/women">Women</a></span></p>
<a href="/cause" class="more">More causes <span class="arrow">&rarr;</span></a>
</section>

<section class="ad">
<div class="wrapper adsense">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive sidebar secondary -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2433408764489440"
     data-ad-slot="4463889242"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</section>


<section class="ad">
<div class="wrapper">
<a href="/subscriptions/new"><img alt="Insider access to the industry&#x27;s most reliable celebrity/charity data" height="250" src="/images/banners/subscriptions-300x250-1587180514.jpg" width="300" /></a>
</div>
</section>

</div>
</aside>
</div>
</div>
<footer>
<div class="full">
<div class="container">
<div class="row">
<div class="col-sm-4">
<h4>About</h4>
<ul>
<li><a href="/about">About the site</a></li>
<li><a href="/about">Our team</a></li>
<li><a href="/advertising">Advertise here</a></li>
<li><a href="/contact">Contact us</a></li>
<li><a href="/subscriptions">Subscriptions</a></li>
<li><a href="/scams">Scam warning</a></li>
</ul>
</div>
<div class="col-sm-6">
<h4>Follow us</h4>
<div class="subscribe-buttons">
<a data-placement="bottom" data-toggle="tooltip" href="https://www.looktothestars.org/feed/rss20.xml" title="Subscribe to our feed">
<i class="fa fa-rss "></i>
<span class="sr-only">RSS feed</span>
</a>
<a class="list-subscribe-show" data-placement="bottom" data-toggle="tooltip" href="#" title="Get our news by email">
<i class="fa fa-envelope-o "></i>
<span class="sr-only">Mailing list</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://twitter.com/looktothestars" rel="nofollow" target="_new" title="Follow us on Twitter">
<i class="fa fa-twitter "></i>
<span class="sr-only">Twitter</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://www.facebook.com/pages/LookToTheStarsorg/43203819581" rel="nofollow" target="_new" title="Follow us on Facebook">
<i class="fa fa-facebook "></i>
<span class="sr-only">Facebook</span>
</a>
</div>

<h4>Legal</h4>
<ul>
<li><a href="/privacy">Privacy &amp; Cookie Policy</a></li>
<li><a href="/terms_of_use">Terms of Use</a></li>
<li><a href="/terms_and_conditions">Subscription Terms</a></li>
</ul>
</div>
<div class="col-sm-2">
<img alt="Footer-logo-1587180514" class="logo" src="/images/footer-logo-1587180514.svg" />
</div>
</div>
</div>
</div>
<div id="copyright">
<div class="full">
<div class="container">
Copyright &copy; 2006-2020 Look To The Stars. All rights reserved.
</div>
</div>
</div>
</footer>
<div id="tip">&nbsp;</div>
<div aria-hidden="true" aria-labelledby="list_subscription_modal_title" class="modal fade" id="list_subscription_modal" role="dialog" tabindex="-1">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-header">
<button class="close" data-dismiss="modal" type="button">
<span aria-hidden="true">&times;</span>
<span class="sr-only">Close</span>
</button>
<h3 class="modal-title" id="list_subscription_modal_title">Get our news delivered straight to your Inbox, for free!</h3>
</div>
<div class="modal-body">
<div id="list_subscriptions_form">
<form accept-charset="UTF-8" action="/list_subscriptions" class="new_list_subscription" data-remote="true" id="new_list_subscription" method="post"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /><input name="authenticity_token" type="hidden" value="u09pi5dhbF2r1/Wf35zTQBjoImYSipHqRfy2pdsPH3Y=" /></div><div class="clearfix"></div>
<div class="form-group">
<label class="sr-only" for="list_subscription_email">Your email address:</label>
<input class="form-control" id="list_subscription_email" name="list_subscription[email]" placeholder="Your email address" required="required" size="30" type="email" />
</div>
<div class="form-group">
<input class="btn btn-primary" data-disable-with="Saving..." name="commit" type="submit" value="Subscribe now" />
<button class="btn btn-default" data-dismiss="modal" type="button">No thanks</button>
</div>
</form>

</div>

</div>
</div>
</div>
</div>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-67727-2', 'looktothestars.org');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');
</script>

<!-- Start Quantcast tag -->
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-f3vrMXzLyb-fU.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->

<script data-main="/javascripts/all-1587185611.js" src="/javascripts/vendor/require-1587185590.js"></script>
</body>
</html>
