<!DOCTYPE html>
<html class="prime" lang="en">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video#">
<meta charset="utf-8">
<meta content="Elton John, Eric McCormack, Kevin Costner, Heidi Klum, Fran Drescher, Patricia Arquette, Donatella Versace, Demi Lovato, Lady Gaga, Christina Hendricks, Brandi Carlile, Zooey Deschanel, Chris Pine, David Furnish, Beck, Lucy Hale, Billy Porter, Elton John AIDS Foundation, celebrity, charity, news" lang="en" name="keywords">
<meta content="The 30th annual Elton John AIDS Foundation Academy Awards Viewing Party took place Sunday, March 27, at West Hollywood Park, LA, hosted by 12-time GRAMMY Award-winning singer/songwriter/actress Lady Gaga, Emmy, Tony, and GRAMMY Award-winning artist Billy Porter and Emmy Award-winning actor Eric McCormack, alongside CEO of Rocket Entertainment and chairman of the Elton John AIDS Foundation David Furnish." lang="en" name="description">
<meta content="index" name="robots">
<meta content="width=device-width, initial-scale=1.0" name="viewport">
<link href="/images/apple-touch-icon-144-precomposed-1632833073.png" rel="apple-touch-icon-precomposed" sizes="144x144">
<link href="/images/apple-touch-icon-114-precomposed-1632833073.png" rel="apple-touch-icon-precomposed" sizes="114x114">
<link href="/images/apple-touch-icon-72-precomposed-1632833073.png" rel="apple-touch-icon-precomposed" sizes="72x72">
<link href="/images/apple-touch-icon-57-precomposed-1632833073.png" rel="apple-touch-icon-precomposed" sizes="57x57">
<meta content="yes" name="apple-mobile-web-app-capable">
<meta content="yes" name="mobile-web-app-capable">
<meta content="black" name="apple-mobile-web-app-status-bar-style">
<link href="/images/favicon-1632833073.png" rel="icon">
<!--[if IE]>
<link href="/images/favicon-1632833073.png" rel="shortcut icon">
<![endif]-->
<meta content="IE=edge" http-equiv="X-UA-Compatible">
<meta content="/images/apple-touch-icon-144-precomposed-1632833073.png" name="msapplication-TileImage">
<meta content="#fee133" name="msapplication-TileColor">
<meta content="Look to the Stars" name="msapplication-tooltip">
<meta content="#fee133" name="msapplication-navbutton-color">
<meta content="/" name="msapplication-starturl">
<meta content="Look to the Stars" name="application-name">
<meta content="Look to the Stars" name="apple-mobile-web-app-title">
<meta content="@looktothestars" name="twitter:site">
<meta content="pk_live_idk4U6tpUXcAV1RMXtw3Rwsh" name="stripe-key">
<meta content="Look to the Stars" property="og:site_name">
<meta content="https://www.looktothestars.org/news/20456-elton-john-aids-foundation-academy-awards-viewing-party-raises-86-million" property="og:url">
<meta content="Elton John AIDS Foundation Academy Awards Viewing Party Raises $8.6 Million" property="og:title">
<meta content="The 30th annual Elton John AIDS Foundation Academy Awards Viewing Party took place Sunday, March 27, at West Hollywood Park, LA, hosted by 12-time GRAMMY Award-winning singer/songwriter/actress Lady Gaga, Emmy, Tony, and GRAMMY Award-winning artist Billy Porter and Emmy Award-winning actor Eric McCormack, alongside CEO of Rocket Entertainment and chairman of the Elton John AIDS Foundation David Furnish." property="og:description">
<meta content="article" property="og:type">
<meta content="2022-03-29T13:30:00Z" property="article:published_time">
<meta content="Celebrity" property="article:tag">
<meta content="Charity" property="article:tag">
<meta content="Elton John" property="article:tag">
<meta content="Eric McCormack" property="article:tag">
<meta content="Kevin Costner" property="article:tag">
<meta content="Heidi Klum" property="article:tag">
<meta content="Fran Drescher" property="article:tag">
<meta content="Patricia Arquette" property="article:tag">
<meta content="Donatella Versace" property="article:tag">
<meta content="Demi Lovato" property="article:tag">
<meta content="Lady Gaga" property="article:tag">
<meta content="Christina Hendricks" property="article:tag">
<meta content="Brandi Carlile" property="article:tag">
<meta content="Zooey Deschanel" property="article:tag">
<meta content="Chris Pine" property="article:tag">
<meta content="David Furnish" property="article:tag">
<meta content="Beck" property="article:tag">
<meta content="Lucy Hale" property="article:tag">
<meta content="Billy Porter" property="article:tag">
<meta content="Elton John AIDS Foundation" property="article:tag">
<meta content="https://www.looktothestars.org/photo/11572-lady-gaga/story_wide.jpg" property="og:image">
<meta content="Elton John AIDS Foundation Academy Awards Viewing Party Raises $8.6 Million" property="twitter:title">
<meta content="The 30th annual Elton John AIDS Foundation Academy Awards Viewing Party took place Sunday, March 27, at West Hollywood Park, LA, hosted by 12-time GRAMMY Award-winning singer/songwriter/actress Lady Gaga, Emmy, Tony, and GRAMMY Award-winning artist Billy Porter and Emmy Award-winning actor Eric McCormack, alongside CEO of Rocket Entertainment and chairman of the Elton John AIDS Foundation David Furnish." property="twitter:description">
<meta content="summary" property="twitter:card">
<meta content="https://www.looktothestars.org/photo/11572-lady-gaga/story_wide.jpg" property="twitter:image">
<link href="https://www.looktothestars.org/news/20456-elton-john-aids-foundation-academy-awards-viewing-party-raises-86-million" rel="canonical">
<title>Elton John AIDS Foundation Academy Awards Viewing Party Raises $8.6 Million - Look to the Stars</title>
<link href="/stylesheets/all-1632833389.css" media="screen" rel="stylesheet" type="text/css" />
<script>
  var username=null;
  window._$ = function(f) { window._$.backlog.unshift(f); };
  window._$.backlog = [];
</script>

<link href="https://www.looktothestars.org/feed/rss20.xml" rel="alternate" title="Latest Celebrity Charity News Items" type="application/rss+xml" />

</head>
<body>
<nav class="navbar navbar-fixed-top navbar-inverse" role="navigation">
<div class="container-fluid">
<div class="navbar-header">
<button class="navbar-toggle" data-target=".navbar-sections-collapse" data-toggle="collapse" type="button">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a class="visible-xs visible-sm navbar-brand" href="/">
Look to the Stars
</a>
</div>
<div class="collapse navbar-collapse navbar-sections-collapse">
<ul class="nav navbar-nav hidden-sm">
<li>
<a class="hidden-sm hidden-xs" href="/">Look to the Stars</a>
</li>
</ul>
<div class="navbar-form navbar-left"><form accept-charset="UTF-8" action="https://www.looktothestars.org/search" class="search" method="get" role="search"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /></div>
<div class="form-group">
<input accesskey="s" autocomplete="off" class="form-control typeahead search-query" name="query" placeholder="Search celebs/causes" required spellcheck="off" type="search">
<input style="visibility: hidden; position: fixed;" type="submit">
</div>
</form>

</div>
<div class="navbar-left navbar-text hidden-xs hidden-sm"><div class="subscribe-buttons">
<a data-placement="bottom" data-toggle="tooltip" href="https://www.looktothestars.org/feed/rss20.xml" title="Subscribe to our feed">
<i class="fa fa-rss "></i>
<span class="sr-only">RSS feed</span>
</a>
<a class="list-subscribe-show" data-placement="bottom" data-toggle="tooltip" href="#" title="Get our news by email">
<i class="fa fa-envelope-o "></i>
<span class="sr-only">Mailing list</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://twitter.com/looktothestars" rel="nofollow" target="_new" title="Follow us on Twitter">
<i class="fa fa-twitter "></i>
<span class="sr-only">Twitter</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://www.facebook.com/pages/LookToTheStarsorg/43203819581" rel="nofollow" target="_new" title="Follow us on Facebook">
<i class="fa fa-facebook "></i>
<span class="sr-only">Facebook</span>
</a>
</div>
</div>
<ul class="nav navbar-nav navbar-right">
<li class="subscribe"><a href="/subscriptions" data-placement="bottom" data-toggle="tooltip" title="Find out about our subscriptions">Subscribe</a></li>
<li><a href="/users/sign_in">Sign in</a></li>
</ul>
<ul class="nav navbar-nav visible-sm visible-xs">
<li><a href="/celebrity" title="4641 celebrities supporting charities">Celebrities</a></li>
<li><a href="/charity" title="2390 charities with celebrity supporters">Charities</a></li>
<li><a href="/news" title="News about celebrities doing good">News</a></li>
<li><a href="/company" title="Companies with celebrity/charity interests">Companies</a></li>
<li><a href="/cause" title="Charitable areas of interest">Causes</a></li>
<li><a href="/calendar" title="Calendar of celebrity charity events">Calendar</a></li>
<li><a href="/about" title="Find out more about this website">About</a></li>

</ul>
</div>
</div>
</nav>
<div id="top"></div>
<nav class="navbar navbar-default hidden-sm hidden-xs" id="section-nav" role="navigation">
<div class="container-fluid">
<ul class="nav navbar-nav">
<li><a href="/celebrity" data-placement="bottom" data-toggle="tooltip" title="4641 celebrities supporting charities">Celebrities</a></li>
<li><a href="/charity" data-placement="bottom" data-toggle="tooltip" title="2390 charities with celebrity supporters">Charities</a></li>
<li><a href="/news" data-placement="bottom" data-toggle="tooltip" title="News about celebrities doing good">News</a></li>
<li><a href="/company" data-placement="bottom" data-toggle="tooltip" title="Companies with celebrity/charity interests">Companies</a></li>
<li><a href="/cause" data-placement="bottom" data-toggle="tooltip" title="Charitable areas of interest">Causes</a></li>
<li><a href="/calendar" data-placement="bottom" data-toggle="tooltip" title="Calendar of celebrity charity events">Calendar</a></li>
<li><a href="/about" data-placement="bottom" data-toggle="tooltip" title="Find out more about this website">About</a></li>

</ul>
</div>
</nav>
<div class="hidden-sm hidden-xs" id="masthead">
<div class="container">
<h4>
<a href="/">
<span class="sr-only">Look to the Stars - the world of celebrity giving</span>
</a>
</h4>
</div>
</div>
<div class="container" id="page" itemscope itemtype="http://schema.org/NewsArticle">
<div id="page-heading">
<ul class="breadcrumb">
<li><a href="/">Home</a></li>
<li><a href="/news">News</a></li>
</ul>
<h1 class="page-header"><span itemprop="name">Elton John AIDS Foundation Academy Awards Viewing Party Raises $8.6 Million</span></h1>
</div>
<div class="row">
<main class="col-md-8" id="main" role="main">
<section id="news-item">
<article>
<p class="date">
<time datetime="2022-03-29T13:30:00Z" itemprop="datePublished">March 29, 2022</time>
</p>
<div class="row">
<div class="col-md-9">
<div id="news-item-body">
<div class="teaser-photo" itemscope itemtype="http://schema.org/ImageObject">
<a href="/celebrity/lady-gaga" itemprop="url"><img alt="Lady Gaga: Profile" class="photo thumbnail teaser " height="150" itemprop="contentURL" src="https://www.looktothestars.org/photo/11572-lady-gaga/teaser-1503604662.jpg" title="Lady Gaga: Profile" width="150" /></a>
</div>

<div class="news-text" itemprop="text"><p>The 30th annual <a href="https://www.looktothestars.org/charity/elton-john-aids-foundation">Elton John AIDS Foundation</a> Academy Awards Viewing Party took place Sunday, March 27, at West Hollywood Park, LA, hosted by 12-time <span class="caps">GRAMMY</span> Award-winning singer/songwriter/actress <a href="https://www.looktothestars.org/celebrity/lady-gaga">Lady Gaga</a>, Emmy, Tony, and <span class="caps">GRAMMY</span> Award-winning artist <a href="https://www.looktothestars.org/celebrity/billy-porter">Billy Porter</a> and Emmy Award-winning actor <a href="https://www.looktothestars.org/celebrity/eric-mccormack">Eric McCormack</a>, alongside <span class="caps">CEO</span> of Rocket Entertainment and chairman of the Elton John <span class="caps">AIDS</span> Foundation <a href="https://www.looktothestars.org/celebrity/david-furnish">David Furnish</a>.</p>
<p>The star-studded gala featured a sparkling performance by six-time <span class="caps">GRAMMY</span> Award-winning artist <a href="https://www.looktothestars.org/celebrity/brandi-carlile">Brandi Carlile</a> and raised $8.6 million for the Foundation&#8217;s lifesaving work to end <span class="caps">AIDS</span>.</p>
<p>Among the crowd of supporters, the Foundation welcomed <a href="https://www.looktothestars.org/celebrity/demi-lovato">Demi Lovato</a>, <a href="https://www.looktothestars.org/celebrity/kevin-costner">Kevin Costner</a>, <a href="https://www.looktothestars.org/celebrity/zooey-deschanel">Zooey Deschanel</a>, <a href="https://www.looktothestars.org/celebrity/donatella-versace">Donatella Versace</a>, <a href="https://www.looktothestars.org/celebrity/fran-drescher">Fran Drescher</a>, <a href="https://www.looktothestars.org/celebrity/patricia-arquette">Patricia Arquette</a>, <a href="https://www.looktothestars.org/celebrity/christina-hendricks">Christina Hendricks</a>, <a href="https://www.looktothestars.org/celebrity/chris-pine">Chris Pine</a>, <a href="https://www.looktothestars.org/celebrity/lucy-hale">Lucy Hale</a>, <a href="https://www.looktothestars.org/celebrity/heidi-klum">Heidi Klum</a>, Chris Sullivan and Chrissy Metz, Andrew Rannells, Sofia Richie, Liam Payne, <a href="https://www.looktothestars.org/celebrity/beck">Beck</a>, Bobby Berk, Emily Hampshire and other distinguished guests. To the delight of the attendees, <a href="https://www.looktothestars.org/celebrity/elton-john">Elton John</a> joined via satellite from his rescheduled Farewell Yellow Brick Road tour stop in Lincoln, Nebraska, to express his appreciation for their support and treat the crowd to a special performance of &#8220;Your Song&#8221; and &#8220;Goodbye Yellow Brick Road.&#8221; Guests were also treated to Limited Edition Elton John Eyewear &#8220;<span class="caps">GOLD</span> <span class="caps">DUST</span>&#8221; frames sold exclusively at Walmart in partnership with Elton John <span class="caps">AIDS</span> Foundation, to wear alongside Elton during his live-streamed performance. Capping off the evening, guests were treated to a full performance by Brandi Carlile and a duet with surprise guest artist, Jake Wesley Rogers, who covered Elton John&#8217;s classic song, &#8220;Rocket Man.&#8221;</p>
<p>The 2022 Academy Awards Viewing Party aligns with the 30th anniversary of the Elton John <span class="caps">AIDS</span> Foundation, and also marks the Foundation&#8217;s return to live events. Since the gala&#8217;s inception in 1992, the Party has supported the Foundation&#8217;s efforts by raising more than $86 million for its lifesaving programs. All funds raised support the Foundation&#8217;s network of partners and local experts across four continents to challenge discrimination, prevent infections and provide treatment, as well as influencing governments to end <span class="caps">AIDS</span>.</p>
<p>&#8220;I&#8217;m so grateful to my friends Lady Gaga, Billy Porter and Eric McCormack for joining David in hosting such an incredible evening, and of course Brandi Carlile for bringing down the house with an electrifying performance,&#8221; says Sir Elton John, Founder, Elton John <span class="caps">AIDS</span> Foundation. &#8220;Most of all, I&#8217;m thankful to all who attended and participated to ensure that we can continue our lifesaving work to end <span class="caps">AIDS</span>. I could feel the love and support all the way from Lincoln, Nebraska!&#8221;</p>
<p>Chef Wayne Elias and Crumble Catering designed and prepared the dinner for the evening, and the live auction was hosted by Simon de Pury. During the high-energy live auction, one of the highest selling lots represented the ultimate fan journey from past to present: two lucky winners received one of Terry O&#8217;Neill&#8217;s iconic images from the 1975 concert, and <span class="caps">VIP</span> tickets to the final Dodgers Stadium performance this November, Elton&#8217;s final performance in the U.S. Adding to the excitement was the sale of an original Andy Warhol, which depicts one of the most famous icons of New York- the Statue of Liberty.</p>
<p>&#8220;Even though Elton was not able to be with us in person, we were so happy to bring Elton to the Oscar Party while he performed live from Nebraska,&#8221; says David Furnish, Chairman of the Elton John <span class="caps">AIDS</span> Foundation. &#8220;It was an especially unforgettable and emotional evening with our sons in attendance for the first time. They made their fathers extremely proud representing our family at the Foundation&#8217;s most important night of the year!&#8221;</p>
<p>&#8220;What an incredible way to mark our 30th annual Academy Awards Viewing Party! A truly memorable evening which was record breaking,&#8221; says Anne Aslett, <span class="caps">CEO</span> of Elton John <span class="caps">AIDS</span> Foundation. &#8220;Thanks to the amazing generosity and compassion of our attendees, we can continue supporting lifesaving programs across the globe to challenge <span class="caps">HIV</span> stigma, prevent infection and provide treatment to those who need it most.&#8221;</p>
<p>Presenting Sponsors of the party included Neuro Brands, Elton John Eyewear, a Walmart exclusive; Christian Lundberg &amp; R. Martin Chavez in partnership with Equality Utah; Bob and Tamar Manoukian. Co-Sponsors included Cadillac, Gilead Sciences, Robert K. Kraft, The Leonard &amp; Judy Lauder Fund, and M•A•C <span class="caps">VIVA</span> <span class="caps">GLAM</span>. The Foundation is especially grateful to the City of West Hollywood for their continued collaboration, and our official airline partner, American Airlines.</p></div>
</div>
</div>
<div class="col-md-3">
<aside id="fact-bar">
<div class="row">
<div class="col-xs-6 col-sm-8 col-md-12">
<div class="panel panel-default panel-facts">
<div class="panel-heading">
<h4>Profiles</h4>
</div>
<div class="panel-body">
<h4>Celebrities:</h4>
<ul class="item-links"><li><a href="https://www.looktothestars.org/celebrity/lady-gaga">Lady Gaga</a></li><li><a href="https://www.looktothestars.org/celebrity/billy-porter">Billy Porter</a></li><li><a href="https://www.looktothestars.org/celebrity/eric-mccormack">Eric McCormack</a></li><li><a href="https://www.looktothestars.org/celebrity/david-furnish">David Furnish</a></li><li><a href="https://www.looktothestars.org/celebrity/brandi-carlile">Brandi Carlile</a></li><li><a href="https://www.looktothestars.org/celebrity/demi-lovato">Demi Lovato</a></li><li><a href="https://www.looktothestars.org/celebrity/kevin-costner">Kevin Costner</a></li><li><a href="https://www.looktothestars.org/celebrity/zooey-deschanel">Zooey Deschanel</a></li><li><a href="https://www.looktothestars.org/celebrity/donatella-versace">Donatella Versace</a></li><li><a href="https://www.looktothestars.org/celebrity/fran-drescher">Fran Drescher</a></li><li><a href="https://www.looktothestars.org/celebrity/patricia-arquette">Patricia Arquette</a></li><li><a href="https://www.looktothestars.org/celebrity/christina-hendricks">Christina Hendricks</a></li><li><a href="https://www.looktothestars.org/celebrity/chris-pine">Chris Pine</a></li><li><a href="https://www.looktothestars.org/celebrity/lucy-hale">Lucy Hale</a></li><li><a href="https://www.looktothestars.org/celebrity/heidi-klum">Heidi Klum</a></li><li><a href="https://www.looktothestars.org/celebrity/beck">Beck</a></li><li><a href="https://www.looktothestars.org/celebrity/elton-john">Elton John</a></li></ul>
<h4>Charities:</h4>
<ul class="item-links"><li><a href="https://www.looktothestars.org/charity/elton-john-aids-foundation">Elton John AIDS Foundation</a></li></ul>
<h4>Causes:</h4>
<ul class="item-links"><li><a href="https://www.looktothestars.org/cause/health">Health</a></li><li><a href="https://www.looktothestars.org/cause/aids-and-hiv">AIDS & HIV</a></li></ul>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</article>
</section>
<section id="disqus_thread"></section>
<script>
  var disqus_shortname = 'ltts';
  var disqus_identifier = 'news_item_20456';
  
  (function() {
      var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
      dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
      (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
  })();
</script>
<noscript>
Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a>
</noscript>
<a class="dsq-brlink" href="http://disqus.com">
comments powered by <span class="logo-disqus">Disqus</span>
</a>
<script type="text/javascript">
var disqus_config = function() {
  this.page.remote_auth_s3 = "e30= d196d78bf813820179b9b2af713eb869543b6806 1648566986";
  this.page.api_key = "v71HFXjyDHpgKjqXp1j1oVVUD8to60eSV7DkFgZpCGV3lYBlb33Hk1Oeh5aqEagt";
  this.sso = {
    name: "Look to the Stars",
    button: "/images/favicon-1632833073.png",
    url: "https://www.looktothestars.org/users/sign_in",
    logout: "https://www.looktothestars.org/users/sign_out",
    height: 700,
    width: 850
  };
}
</script>


<section id="related-news">
<h4>Related news stories</h4>
<section><section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/20453-stars-to-perform-at-musicares-music-on-a-mission-presented-by-gibson"><img alt="Stars To Perform At MusiCares: Music On A Mission Presented by Gibson" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/4794-brandi-carlile/teaser-1503191663.jpg" title="Stars To Perform At MusiCares: Music On A Mission Presented by Gibson" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/20453-stars-to-perform-at-musicares-music-on-a-mission-presented-by-gibson">Stars To Perform At MusiCares: Music On A Mission Presented by Gibson</a>
<span class="date">Mar 29, 2022</span>
</h4>
GRAMMY Award-winning artists Brandi Carlile, Shawn Colvin, Jason Isbell, Jesse &amp; Joy, k.d. lang, and Fantastic Negrito, Latin GRAMMY Award winners Gian Marco and Dante Spinetta, GRAMMY Award nominee Amythyst Kiah, along with Fitz of Fitz and the Tantrums, morgxn, Zach Person, and Emily Wolfe will join the performance lineup at the MusiCares: Music on a Mission Presented by Gibson on Wed, March 30, 2022, at 5 p.m. PT/8 p.m. ET.
<a href="/news/20453-stars-to-perform-at-musicares-music-on-a-mission-presented-by-gibson" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>

</section>
<section><ul class="headlines">
<li>
<h4>
<a href="https://www.looktothestars.org/news/20444-celebrities-spreading-solidarity-and-raising-funds-for-ukraine">Celebrities Spreading Solidarity and Raising Funds for Ukraine</a>
<span class="date">Mar 14, 2022</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/20442-brandi-carlile-to-be-honored-at-human-rights-campaign-2022-los-angeles-dinner">Brandi Carlile To Be Honored At Human Rights Campaign 2022 Los Angeles Dinner</a>
<span class="date">Mar 11, 2022</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/20435-lady-gaga-billy-porter-and-eric-mccormack-to-co-host-30th-annual-elton-john-aids-foundation-academy-awards-viewing-party">Lady Gaga, Billy Porter and Eric McCormack To Co-Host 30th Annual Elton John AIDS Foundation Academy Awards Viewing Party</a>
<span class="date">Mar  7, 2022</span>
</h4>
</li>
</ul>
</section>

</section>

<section id="related-videos">
<h4>Related videos</h4>
<div class="row">
<div class="col-md-6"><div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/1521-lady-gaga-students-on-teen-mental-health-first-aid"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="Lady Gaga + Students on teen Mental Health First Aid!" class="video thumb" height="90" src="https://i.ytimg.com/vi/-nXw1I-F-38/default.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/1521-lady-gaga-students-on-teen-mental-health-first-aid">Lady Gaga + Students on teen Mental Health First Aid!</a></h5>
</div>
</div>
<div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/1503-elton-john-visits-atlanta-to-launch-our-aidsfree-campaign"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="Elton John visits Atlanta to launch our #AIDSfree campaign" class="video thumb" height="90" src="https://i.ytimg.com/vi/XWKuWEPK6dE/default.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/1503-elton-john-visits-atlanta-to-launch-our-aidsfree-campaign">Elton John visits Atlanta to launch our #AIDSfree campaign</a></h5>
</div>
</div>

</div>
<div class="col-md-6"><div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/1380-your-substitute-teacher-lady-gaga"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="Your Substitute Teacher: Lady Gaga" class="video thumb" height="90" src="https://i.ytimg.com/vi/ZFIlPub745A/default.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/1380-your-substitute-teacher-lady-gaga">Your Substitute Teacher: Lady Gaga</a></h5>
</div>
</div>
<div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/1368-clark-the-shark-read-by-chris-pine"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="Clark the Shark Read by Chris Pine" class="video thumb" height="90" src="https://i.ytimg.com/vi/lgZRMptA0Lk/default.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/1368-clark-the-shark-read-by-chris-pine">Clark the Shark Read by Chris Pine</a></h5>
</div>
</div>

</div>
</div>
<a href="/video" class="more">More videos <span class="arrow">&rarr;</span></a>

</section>
<section id="latest-news">
<h4><a href="/news">Latest news</a></h4>
<section><section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/20453-stars-to-perform-at-musicares-music-on-a-mission-presented-by-gibson"><img alt="Stars To Perform At MusiCares: Music On A Mission Presented by Gibson" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/4794-brandi-carlile/teaser-1503191663.jpg" title="Stars To Perform At MusiCares: Music On A Mission Presented by Gibson" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/20453-stars-to-perform-at-musicares-music-on-a-mission-presented-by-gibson">Stars To Perform At MusiCares: Music On A Mission Presented by Gibson</a>
<span class="date">Mar 29, 2022</span>
</h4>
GRAMMY Award-winning artists Brandi Carlile, Shawn Colvin, Jason Isbell, Jesse &amp; Joy, k.d. lang, and Fantastic Negrito, Latin GRAMMY Award winners Gian Marco and Dante Spinetta, GRAMMY Award nominee Amythyst Kiah, along with Fitz of Fitz and the Tantrums, morgxn, Zach Person, and Emily Wolfe will join the performance lineup at the MusiCares: Music on a Mission Presented by Gibson on Wed, March 30, 2022, at 5 p.m. PT/8 p.m. ET.
<a href="/news/20453-stars-to-perform-at-musicares-music-on-a-mission-presented-by-gibson" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>

</section>
<section><ul class="headlines">
<li>
<h4>
<a href="https://www.looktothestars.org/news/20454-orlando-bloom-in-moldova-to-meet-refugee-children-fleeing-ukraine-war">Orlando Bloom in Moldova to Meet Refugee Children Fleeing Ukraine War</a>
<span class="date">Mar 28, 2022</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/20450-nemours-childrens-health-and-michael-phelps-foundation-launch-video-series-for-parents">Nemours Children's Health and Michael Phelps Foundation Launch Video Series for Parents</a>
<span class="date">Mar 22, 2022</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/20449-homeboy-industries-lo-maximo-awards-and-fundraising-gala-hosted-by-jane-fonda-and-lily-tomlin">Homeboy Industries Lo Máximo Awards and Fundraising Gala Hosted by Jane Fonda and Lily Tomlin</a>
<span class="date">Mar 21, 2022</span>
</h4>
</li>
</ul>
</section>

<a href="/news" class="more">More news <span class="arrow">&rarr;</span></a>
</section>

</main>
<aside class="col-md-4 col-xs-12">
<div id="sidebar">

<section class="ad">
<div class="wrapper adsense">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2433408764489440"
     data-ad-slot="2987156042"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</section>

<section>
<h3><a href="/celebrity">Top celebrities</a></h3>
<ul class="top-thumbs">
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/elton-john" class="image-link"><img alt="Elton John" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/6341-elton-john/small_square-1503121378.jpg" title="Elton John" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/elton-john">Elton John</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/bill-clinton" class="image-link"><img alt="Bill Clinton" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/24-bill-clinton/small_square-1503121377.jpg" title="Bill Clinton" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/bill-clinton">Bill Clinton</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/sting" class="image-link"><img alt="Sting" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/134-sting/small_square-1503121378.jpg" title="Sting" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/sting">Sting</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/annie-lennox" class="image-link"><img alt="Annie Lennox" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/2984-annie-lennox/small_square-1503121378.jpg" title="Annie Lennox" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/annie-lennox">Annie Lennox</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/paul-mccartney" class="image-link"><img alt="Paul McCartney" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/7581-paul-mccartney/small_square-1503121378.jpg" title="Paul McCartney" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/paul-mccartney">Paul McCartney</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/bono" class="image-link"><img alt="Bono" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/9-bono/small_square-1503121378.jpg" title="Bono" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/bono">Bono</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/lady-gaga" class="image-link"><img alt="Lady Gaga" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/11572-lady-gaga/small_square-1503620652.jpg" title="Lady Gaga" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/lady-gaga">Lady Gaga</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/george-clooney" class="image-link"><img alt="George Clooney" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/3-george-clooney/small_square-1503121378.jpg" title="George Clooney" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/george-clooney">George Clooney</a></div>
</div>
</div>
</li>
</ul>
<a href="/celebrity" class="more">More celebrities <span class="arrow">&rarr;</span></a>
</section>
<section>
<h3><a href="/charity">Top charities</a></h3>
<ul class="top-thumbs">
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/unicef" class="image-link"><img alt="UNICEF" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/7146-unicef/small_square-1503121378.jpg" title="UNICEF" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/unicef">UNICEF</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/peta" class="image-link"><img alt="PETA" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1242-peta/small_square-1503121378.jpg" title="PETA" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/peta">PETA</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/elton-john-aids-foundation" class="image-link"><img alt="Elton John AIDS Foundation" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/6908-elton-john-aids-foundation/small_square-1503121378.jpg" title="Elton John AIDS Foundation" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/elton-john-aids-foundation">Elton John AIDS Foundation</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/red-cross" class="image-link"><img alt="Red Cross" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1295-red-cross/small_square-1503121378.jpg" title="Red Cross" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/red-cross">Red Cross</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/save-the-children" class="image-link"><img alt="Save the Children" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1251-save-the-children/small_square-1503121378.jpg" title="Save the Children" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/save-the-children">Save the Children</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/boys-and-girls-clubs-of-america" class="image-link"><img alt="Boys & Girls Clubs of America" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1259-boys-and-girls-clubs-of-america/small_square-1503129220.jpg" title="Boys & Girls Clubs of America" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/boys-and-girls-clubs-of-america">Boys & Girls Clubs of America</a></div>
</div>
</div>
</li>
</ul>
<a href="/charity" class="more">More charities <span class="arrow">&rarr;</span></a>
</section>

<section>
<h3><a href="/cause">Top causes</a></h3>
<p class="link-cloud"><span style="font-size:84%"><a href="https://www.looktothestars.org/cause/aids-and-hiv">AIDS & HIV</a></span>&emsp;
<span style="font-size:86%"><a href="https://www.looktothestars.org/cause/animals">Animals</a></span>&emsp;
<span style="font-size:99%"><a href="https://www.looktothestars.org/cause/at-risk-disadvantaged-youths">At-Risk/Disadvantaged Youths</a></span>&emsp;
<span style="font-size:90%"><a href="https://www.looktothestars.org/cause/cancer">Cancer</a></span>&emsp;
<span style="font-size:144%"><a href="https://www.looktothestars.org/cause/children">Children</a></span>&emsp;
<span style="font-size:105%"><a href="https://www.looktothestars.org/cause/education">Education</a></span>&emsp;
<span style="font-size:89%"><a href="https://www.looktothestars.org/cause/environment">Environment</a></span>&emsp;
<span style="font-size:128%"><a href="https://www.looktothestars.org/cause/health">Health</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/cause/human-rights">Human Rights</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/cause/miscellaneous">Miscellaneous</a></span>&emsp;
<span style="font-size:92%"><a href="https://www.looktothestars.org/cause/poverty">Poverty</a></span>&emsp;
<span style="font-size:85%"><a href="https://www.looktothestars.org/cause/women">Women</a></span></p>
<a href="/cause" class="more">More causes <span class="arrow">&rarr;</span></a>
</section>

<section class="ad">
<div class="wrapper adsense">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive sidebar secondary -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2433408764489440"
     data-ad-slot="4463889242"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</section>


<section class="ad">
<div class="wrapper">
<a href="/subscriptions/new"><img alt="Insider access to the industry&#x27;s most reliable celebrity/charity data" height="250" src="/images/banners/subscriptions-300x250-1632833073.jpg" width="300" /></a>
</div>
</section>

</div>
</aside>
</div>
</div>
<footer>
<div class="full">
<div class="container">
<div class="row">
<div class="col-sm-4">
<h4>About</h4>
<ul>
<li><a href="/about">About the site</a></li>
<li><a href="/about">Our team</a></li>
<li><a href="/advertising">Advertise here</a></li>
<li><a href="/contact">Contact us</a></li>
<li><a href="/subscriptions">Subscriptions</a></li>
<li><a href="/scams">Scam warning</a></li>
</ul>
</div>
<div class="col-sm-6">
<h4>Follow us</h4>
<div class="subscribe-buttons">
<a data-placement="bottom" data-toggle="tooltip" href="https://www.looktothestars.org/feed/rss20.xml" title="Subscribe to our feed">
<i class="fa fa-rss "></i>
<span class="sr-only">RSS feed</span>
</a>
<a class="list-subscribe-show" data-placement="bottom" data-toggle="tooltip" href="#" title="Get our news by email">
<i class="fa fa-envelope-o "></i>
<span class="sr-only">Mailing list</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://twitter.com/looktothestars" rel="nofollow" target="_new" title="Follow us on Twitter">
<i class="fa fa-twitter "></i>
<span class="sr-only">Twitter</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://www.facebook.com/pages/LookToTheStarsorg/43203819581" rel="nofollow" target="_new" title="Follow us on Facebook">
<i class="fa fa-facebook "></i>
<span class="sr-only">Facebook</span>
</a>
</div>

<h4>Legal</h4>
<ul>
<li><a href="/privacy">Privacy &amp; Cookie Policy</a></li>
<li><a href="/terms_of_use">Terms of Use</a></li>
<li><a href="/terms_and_conditions">Subscription Terms</a></li>
</ul>
</div>
<div class="col-sm-2">
<img alt="Footer-logo-1632833073" class="logo" src="/images/footer-logo-1632833073.svg" />
</div>
</div>
</div>
</div>
<div id="copyright">
<div class="full">
<div class="container">
Copyright &copy; 2006-2022 Look To The Stars. All rights reserved.
</div>
</div>
</div>
</footer>
<div id="tip">&nbsp;</div>
<div aria-hidden="true" aria-labelledby="list_subscription_modal_title" class="modal fade" id="list_subscription_modal" role="dialog" tabindex="-1">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-header">
<button class="close" data-dismiss="modal" type="button">
<span aria-hidden="true">&times;</span>
<span class="sr-only">Close</span>
</button>
<h3 class="modal-title" id="list_subscription_modal_title">Get our news delivered straight to your Inbox, for free!</h3>
</div>
<div class="modal-body">
<div id="list_subscriptions_form">
<form accept-charset="UTF-8" action="/list_subscriptions" class="new_list_subscription" data-remote="true" id="new_list_subscription" method="post"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /><input name="authenticity_token" type="hidden" value="pNLJkPI4vEDVOHWfQIJKsA2jH5o8ot5lbJ0mj5F1lrs=" /></div><div class="clearfix"></div>
<div class="form-group">
<label class="sr-only" for="list_subscription_email">Your email address:</label>
<input class="form-control" id="list_subscription_email" name="list_subscription[email]" placeholder="Your email address" required="required" size="30" type="email" />
</div>
<div class="form-group">
<input class="btn btn-primary" data-disable-with="Saving..." name="commit" type="submit" value="Subscribe now" />
<button class="btn btn-default" data-dismiss="modal" type="button">No thanks</button>
</div>
</form>

</div>

</div>
</div>
</div>
</div>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-67727-2', 'looktothestars.org');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');
</script>

<script data-main="/javascripts/all-1632833386.js" src="/javascripts/vendor/require-1632833365.js"></script>
</body>
</html>
