<!DOCTYPE html>
<html class="prime" lang="en">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video#">
<meta charset="utf-8">
<meta content="Hill Harper, celebrity, charity, news" lang="en" name="keywords">
<meta content="Profile of Hill Harper&#x27;s support for charities including Big Brothers Big Sisters, Boys &amp; Girls Clubs of America, and Leeza&#x27;s Place. We have 41 articles about Hill Harper&#x27;s philanthropy. " lang="en" name="description">
<meta content="index" name="robots">
<meta content="width=device-width, initial-scale=1.0" name="viewport">
<link href="/images/apple-touch-icon-144-precomposed-1632833073.png" rel="apple-touch-icon-precomposed" sizes="144x144">
<link href="/images/apple-touch-icon-114-precomposed-1632833073.png" rel="apple-touch-icon-precomposed" sizes="114x114">
<link href="/images/apple-touch-icon-72-precomposed-1632833073.png" rel="apple-touch-icon-precomposed" sizes="72x72">
<link href="/images/apple-touch-icon-57-precomposed-1632833073.png" rel="apple-touch-icon-precomposed" sizes="57x57">
<meta content="yes" name="apple-mobile-web-app-capable">
<meta content="yes" name="mobile-web-app-capable">
<meta content="black" name="apple-mobile-web-app-status-bar-style">
<link href="/images/favicon-1632833073.png" rel="icon">
<!--[if IE]>
<link href="/images/favicon-1632833073.png" rel="shortcut icon">
<![endif]-->
<meta content="IE=edge" http-equiv="X-UA-Compatible">
<meta content="/images/apple-touch-icon-144-precomposed-1632833073.png" name="msapplication-TileImage">
<meta content="#fee133" name="msapplication-TileColor">
<meta content="Look to the Stars" name="msapplication-tooltip">
<meta content="#fee133" name="msapplication-navbutton-color">
<meta content="/" name="msapplication-starturl">
<meta content="Look to the Stars" name="application-name">
<meta content="Look to the Stars" name="apple-mobile-web-app-title">
<meta content="@looktothestars" name="twitter:site">
<meta content="pk_live_idk4U6tpUXcAV1RMXtw3Rwsh" name="stripe-key">
<meta content="Look to the Stars" property="og:site_name">
<meta content="https://www.looktothestars.org/celebrity/hill-harper" property="og:url">
<meta content="Hill Harper: Charity Work &amp; Causes" property="og:title">
<meta content="Profile of Hill Harper's support for charities including Big Brothers Big Sisters, Boys &amp; Girls Clubs of America, and Leeza's Place. We have 41 articles about Hill Harper's philanthropy. " property="og:description">
<meta content="summary" property="twitter:card">
<meta content="Hill Harper: Charity Work &amp; Causes" property="twitter:title">
<meta content="Profile of Hill Harper's support for charities including Big Brothers Big Sisters, Boys &amp; Girls Clubs of America, and Leeza's Place. We have 41 articles about Hill Harper's philanthropy. " property="twitter:description">
<meta content="https://www.looktothestars.org/photo/2494-hill-harper/story_half_width.jpg" property="twitter:image">
<meta content="https://www.looktothestars.org/photo/2494-hill-harper/story_half_width.jpg" property="og:image">
<link href="https://www.looktothestars.org/celebrity/hill-harper" rel="canonical">
<title>Hill Harper: Charity Work &amp; Causes - Look to the Stars</title>
<link href="/stylesheets/all-1632833389.css" media="screen" rel="stylesheet" type="text/css" />
<script>
  var username=null;
  window._$ = function(f) { window._$.backlog.unshift(f); };
  window._$.backlog = [];
</script>

<link href="https://www.looktothestars.org/feed/rss20.xml" rel="alternate" title="Latest Celebrity Charity News Items" type="application/rss+xml" />
<link href="https://www.looktothestars.org/celebrity/hill-harper/rss20.xml" rel="alternate" title="Latest Charity News About Hill Harper" type="application/rss+xml" />
</head>
<body>
<nav class="navbar navbar-fixed-top navbar-inverse" role="navigation">
<div class="container-fluid">
<div class="navbar-header">
<button class="navbar-toggle" data-target=".navbar-sections-collapse" data-toggle="collapse" type="button">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a class="visible-xs visible-sm navbar-brand" href="/">
Look to the Stars
</a>
</div>
<div class="collapse navbar-collapse navbar-sections-collapse">
<ul class="nav navbar-nav hidden-sm">
<li>
<a class="hidden-sm hidden-xs" href="/">Look to the Stars</a>
</li>
</ul>
<div class="navbar-form navbar-left"><form accept-charset="UTF-8" action="https://www.looktothestars.org/search" class="search" method="get" role="search"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /></div>
<div class="form-group">
<input accesskey="s" autocomplete="off" class="form-control typeahead search-query" name="query" placeholder="Search celebs/causes" required spellcheck="off" type="search">
<input style="visibility: hidden; position: fixed;" type="submit">
</div>
</form>

</div>
<div class="navbar-left navbar-text hidden-xs hidden-sm"><div class="subscribe-buttons">
<a data-placement="bottom" data-toggle="tooltip" href="https://www.looktothestars.org/feed/rss20.xml" title="Subscribe to our feed">
<i class="fa fa-rss "></i>
<span class="sr-only">RSS feed</span>
</a>
<a class="list-subscribe-show" data-placement="bottom" data-toggle="tooltip" href="#" title="Get our news by email">
<i class="fa fa-envelope-o "></i>
<span class="sr-only">Mailing list</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://twitter.com/looktothestars" rel="nofollow" target="_new" title="Follow us on Twitter">
<i class="fa fa-twitter "></i>
<span class="sr-only">Twitter</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://www.facebook.com/pages/LookToTheStarsorg/43203819581" rel="nofollow" target="_new" title="Follow us on Facebook">
<i class="fa fa-facebook "></i>
<span class="sr-only">Facebook</span>
</a>
</div>
</div>
<ul class="nav navbar-nav navbar-right">
<li class="subscribe"><a href="/subscriptions" data-placement="bottom" data-toggle="tooltip" title="Find out about our subscriptions">Subscribe</a></li>
<li><a href="/users/sign_in">Sign in</a></li>
</ul>
<ul class="nav navbar-nav visible-sm visible-xs">
<li><a href="/celebrity" title="4641 celebrities supporting charities">Celebrities</a></li>
<li><a href="/charity" title="2390 charities with celebrity supporters">Charities</a></li>
<li><a href="/news" title="News about celebrities doing good">News</a></li>
<li><a href="/company" title="Companies with celebrity/charity interests">Companies</a></li>
<li><a href="/cause" title="Charitable areas of interest">Causes</a></li>
<li><a href="/calendar" title="Calendar of celebrity charity events">Calendar</a></li>
<li><a href="/about" title="Find out more about this website">About</a></li>

</ul>
</div>
</div>
</nav>
<div id="top"></div>
<nav class="navbar navbar-default hidden-sm hidden-xs" id="section-nav" role="navigation">
<div class="container-fluid">
<ul class="nav navbar-nav">
<li><a href="/celebrity" data-placement="bottom" data-toggle="tooltip" title="4641 celebrities supporting charities">Celebrities</a></li>
<li><a href="/charity" data-placement="bottom" data-toggle="tooltip" title="2390 charities with celebrity supporters">Charities</a></li>
<li><a href="/news" data-placement="bottom" data-toggle="tooltip" title="News about celebrities doing good">News</a></li>
<li><a href="/company" data-placement="bottom" data-toggle="tooltip" title="Companies with celebrity/charity interests">Companies</a></li>
<li><a href="/cause" data-placement="bottom" data-toggle="tooltip" title="Charitable areas of interest">Causes</a></li>
<li><a href="/calendar" data-placement="bottom" data-toggle="tooltip" title="Calendar of celebrity charity events">Calendar</a></li>
<li><a href="/about" data-placement="bottom" data-toggle="tooltip" title="Find out more about this website">About</a></li>

</ul>
</div>
</nav>
<div class="hidden-sm hidden-xs" id="masthead">
<div class="container">
<h4>
<a href="/">
<span class="sr-only">Look to the Stars - the world of celebrity giving</span>
</a>
</h4>
</div>
</div>
<div class="container" id="page" itemscope itemtype="http://schema.org/Person">
<div id="page-heading">
<ul class="breadcrumb">
<li><a href="/">Home</a></li>
<li><a href="/celebrity">Celebrities</a></li>
</ul>
<h1 class="page-header"><span itemprop="name">Hill Harper</span> <small>Charity Work, Events and Causes</small></h1>
</div>
<div class="row">
<main class="col-md-8" id="main" role="main">
<section id="celebrity">
<div class="media">
<div class="media-left">
<img alt="Hill Harper" class="photo thumbnail teaser " height="150" itemprop="image" src="https://www.looktothestars.org/photo/2494-hill-harper/teaser-1503152002.jpg" title="Hill Harper" width="150" />
</div>
<div class="media-body">
<div class="row">
<div class="col-xs-6">
<div class="key-numbers">
<a class="stat" href="#charities">
<div class="num">17</div>
charities
</a>
<a class="stat" href="#causes">
<div class="num">15</div>
causes
</a>
</div>
</div>
<div class="col-xs-6">
<div class="key-numbers">
<a class="stat" href="#related-news">
<div class="num">41</div>
articles
</a>
<a class="stat" href="#related-videos">
<div class="num">1</div>
video
</a>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="truncate" id="celebrity-bio">
<div>
<div itemprop="description"><p>Hill Harper is a film, television and stage actor known for his work on <em><span class="caps">CSI</span></em>.</p>
<p>Harper founded the <a href="https://www.looktothestars.org/charity/manifest-your-destiny-foundation">Manifest Your Destiny Foundation</a> to actualizing the ideas, philosophies, and strategies detailed in his two books, Letters to a Young Brother: MANifest Your Destiny and Letters to a Young Sister: DeFINE Your Destiny.</p>
<p>In 2008, he participated in Yes We Can, a music video supporting Barack Obama, produced by <a href="https://www.looktothestars.org/celebrity/will-i-am">will.i.am</a>.</p>
<p>He recently launched a social network ForRealSolutions.com aimed at encouraging solutions to some of society&#8217;s challenges.</p>
<p>He endorsed the 10,000 Bookbags back to school backpack campaign to help local disadvantaged children with Urban Change Ministries founder Pastor Jay Cameron of the Life Center and R&amp;B singer Ginuwine.</p></div>
<p class="copyright">
Copyright &copy; 2021 Look to the Stars, All rights reserved.
</p>
</div>
</section>
<section id="charity-connections">
<div id="supported-charities">
<a name="charities"></a>
<h3>
Charities &amp; foundations supported
<span class="badge">17</span>
</h3>
<p class="muted">
Hill Harper has supported the following charities listed on this site:
</p>
<div class="row">
<div class="col-sm-6"><ul class="item-links"><li><a href="https://www.looktothestars.org/charity/alzheimers-association">Alzheimer's Association</a></li><li><a href="https://www.looktothestars.org/charity/american-heart-association">American Heart Association</a></li><li><a href="https://www.looktothestars.org/charity/american-stroke-association">American Stroke Association</a></li><li><a href="https://www.looktothestars.org/charity/barbara-davis-center-for-childhood-diabetes">Barbara Davis Center for Childhood Diabetes</a></li><li><a href="https://www.looktothestars.org/charity/big-brothers-big-sisters">Big Brothers Big Sisters</a></li><li><a href="https://www.looktothestars.org/charity/black-aids-institute">Black AIDS Institute</a></li><li><a href="https://www.looktothestars.org/charity/boys-and-girls-clubs-of-america">Boys & Girls Clubs of America</a></li><li><a href="https://www.looktothestars.org/charity/eracism-foundation">Eracism Foundation</a></li><li><a href="https://www.looktothestars.org/charity/international-myeloma-foundation">International Myeloma Foundation</a></li></ul></div>
<div class="col-sm-6"><ul class="item-links"><li><a href="https://www.looktothestars.org/charity/leezas-place">Leeza's Place</a></li><li><a href="https://www.looktothestars.org/charity/lupus-la">Lupus LA</a></li><li><a href="https://www.looktothestars.org/charity/magic-johnson-foundation">Magic Johnson Foundation</a></li><li><a href="https://www.looktothestars.org/charity/make-a-film-foundation">Make A Film Foundation</a></li><li><a href="https://www.looktothestars.org/charity/manifest-your-destiny-foundation">Manifest Your Destiny Foundation</a></li><li><a href="https://www.looktothestars.org/charity/moste">MOSTe</a></li><li><a href="https://www.looktothestars.org/charity/somaly-mam-foundation">Somaly Mam Foundation</a></li><li><a href="https://www.looktothestars.org/charity/united-negro-college-fund">United Negro College Fund</a></li></ul></div>
</div>
<aside>
<p class="small muted">
Did we miss something?
<a href="/contact?about=error">Let us know!</a>
</p>
</aside>
</div>
<div class="row">
<div class="col-md-5 col-lg-6">
<div class="panel panel-default panel-similar">
<div class="panel-heading">
<h4>Other supporters of the same charities & foundations</h4>
</div>
<div class="panel-body">
<p class="link-cloud"><span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/anderson-cooper">Anderson Cooper</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/andie-macdowell">Andie MacDowell</a></span>&emsp;
<span style="font-size:114%"><a href="https://www.looktothestars.org/celebrity/anthony-anderson">Anthony Anderson</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/aretha-franklin">Aretha Franklin</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/ashanti">Ashanti</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/bella-thorne">Bella Thorne</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/ben-vereen">Ben Vereen</a></span>&emsp;
<span style="font-size:114%"><a href="https://www.looktothestars.org/celebrity/daisy-fuentes">Daisy Fuentes</a></span>&emsp;
<span style="font-size:114%"><a href="https://www.looktothestars.org/celebrity/jane-seymour">Jane Seymour</a></span>&emsp;
<span style="font-size:114%"><a href="https://www.looktothestars.org/celebrity/jennie-garth">Jennie Garth</a></span>&emsp;
<span style="font-size:114%"><a href="https://www.looktothestars.org/celebrity/kathy-griffin">Kathy Griffin</a></span>&emsp;
<span style="font-size:114%"><a href="https://www.looktothestars.org/celebrity/laila-ali">Laila Ali</a></span>&emsp;
<span style="font-size:114%"><a href="https://www.looktothestars.org/celebrity/patrick-warburton">Patrick Warburton</a></span>&emsp;
<span style="font-size:114%"><a href="https://www.looktothestars.org/celebrity/sharon-stone">Sharon Stone</a></span>&emsp;
<span style="font-size:144%"><a href="https://www.looktothestars.org/celebrity/susan-sarandon">Susan Sarandon</a></span></p>
</div>
</div>
</div>
<div class="col-md-7 col-lg-6">
<div class="insights-hidden panel panel-insights">
<div class="panel-heading">
<h4>
Insights
</h4>
</div>
<div class="panel-body">
<div class="key-numbers">
<div class="stat">
<div class="num">
<span data-toggle="tooltip" title="Available to Insider Access subscribers only"><i class="fa fa-lock "></i></span>
</div>
Activity
<span class="what-is-this" data-placement="bottom" data-toggle="tooltip" title="Number from 0 to 100 indicating relative level of charitable activity"><i class="fa fa-question-circle "></i></span>
</div>
<div class="stat">
<div class="num">
<span data-toggle="tooltip" title="Available to Insider Access subscribers only"><i class="fa fa-lock "></i></span>
</div>
Social reach
<span class="what-is-this" data-placement="bottom" data-toggle="tooltip" title="Number from 0 to 100 indicating relative level of social media following"><i class="fa fa-question-circle "></i></span>
</div>
</div>
<p data-toggle="tooltip" title="Available to subscribers only">
<i class="fa fa-globe "></i>
<span class="num">1</span>
related place
</p>
<div class="google-trends">
<i class="fa fa-line-chart "></i>
<a class="show-chart" href="#">Google trends for "Hill Harper"</a>
<div class="chart">
Available to Insiders only
</div>
</div>
</div>
<div class="panel-footer">
<a class="small" href="/subscriptions/new">
<strong>Get Insider Access</strong> to these insights & more...
</a>
</div>
</div>

</div>
</div>
</section>
<section id="supported-causes">
<a name="causes"></a>
<h3>
Causes supported
<span class="badge">15</span>
</h3>
<p class="item-links">
<a href="https://www.looktothestars.org/cause/aids-and-hiv">AIDS & HIV</a>, <a href="https://www.looktothestars.org/cause/alzheimers-disease">Alzheimer's Disease</a>, <a href="https://www.looktothestars.org/cause/at-risk-disadvantaged-youths">At-Risk/Disadvantaged Youths</a>, <a href="https://www.looktothestars.org/cause/cancer">Cancer</a>, <a href="https://www.looktothestars.org/cause/children">Children</a>, <a href="https://www.looktothestars.org/cause/creative-arts">Creative Arts</a>, <a href="https://www.looktothestars.org/cause/diabetes">Diabetes</a>, <a href="https://www.looktothestars.org/cause/education">Education</a>, <a href="https://www.looktothestars.org/cause/health">Health</a>, <a href="https://www.looktothestars.org/cause/human-rights">Human Rights</a>, <a href="https://www.looktothestars.org/cause/lupus">Lupus</a>, <a href="https://www.looktothestars.org/cause/peace">Peace</a>, <a href="https://www.looktothestars.org/cause/rape-sexual-abuse">Rape/Sexual Abuse</a>, <a href="https://www.looktothestars.org/cause/slavery-and-human-trafficking">Slavery & Human Trafficking</a>, <a href="https://www.looktothestars.org/cause/women">Women</a></p>
<a name="contact"></a>
<div class="panel panel-default panel-contact-celeb" id="contact-celeb">
<div class="panel-heading">
<h4>Contact Hill Harper</h4>
</div>
<div class="panel-body">
<p>
You can contact Hill Harper using details from <strong><a href="https://www.contactanycelebrity.com/cac/101.html" class="contact-service" rel="nofollow">this service</a></strong>.
(Or read our <a href="https://www.looktothestars.org/how_to_contact_celebrities">advice on how to contact celebrities</a>)
</p>
</div>
</div>
</section>
<section id="related-news">
<a name="related-news"></a>
<h3>
<a href="/celebrity/hill-harper/news">Related charity news and events <span class="badge">41</span></a>
</h3>
<section><section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/20172-vivica-a-fox-and-kym-feltus-join-forces-for-the-ultimate-virtual-womens-empowerment-festival"><img alt="Vivica A. Fox and Kym Feltus Join Forces For the Ultimate Virtual Women&#x27;s Empowerment Festival" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/2494-hill-harper/teaser-1503152002.jpg" title="Vivica A. Fox and Kym Feltus Join Forces For the Ultimate Virtual Women&#x27;s Empowerment Festival" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/20172-vivica-a-fox-and-kym-feltus-join-forces-for-the-ultimate-virtual-womens-empowerment-festival">Vivica A. Fox and Kym Feltus Join Forces For the Ultimate Virtual Women's Empowerment Festival</a>
<span class="date">May 14, 2021</span>
</h4>
Motivational speaker and philanthropist Kym Feltus has announced the launch of what is bound to be the premier virtual women&#8217;s empowerment event of the year!
<a href="/news/20172-vivica-a-fox-and-kym-feltus-join-forces-for-the-ultimate-virtual-womens-empowerment-festival" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>
<section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/20002-hill-harper-leads-24m-initiative-to-address-early-learning-crisis"><img alt="Hill Harper Leads $24M Initiative to Address Early Learning Crisis" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/2494-hill-harper/teaser-1503152002.jpg" title="Hill Harper Leads $24M Initiative to Address Early Learning Crisis" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/20002-hill-harper-leads-24m-initiative-to-address-early-learning-crisis">Hill Harper Leads $24M Initiative to Address Early Learning Crisis</a>
<span class="date">Nov 23, 2020</span>
</h4>
Hill Harper, star of ABC&#8217;s #1 drama &#8220;The Good Doctor&#8221; and best-selling author, has announced the launch of the Keep Learning Alive campaign which will provide early learning software to up to 400,000 students and 20,000 classrooms facing unprecedented hardship in the midst of the pandemic.
<a href="/news/20002-hill-harper-leads-24m-initiative-to-address-early-learning-crisis" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>
<section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/18983-hill-harper-attends-international-centre-for-missing-and-exploited-children-gala"><img alt="Hill Harper Attends International Centre for Missing and Exploited Children Gala" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/12728-hill-harper-at-international-centre-for-missing-and-exploited-childrens-gala/teaser-1557257109.jpg" title="Hill Harper Attends International Centre for Missing and Exploited Children Gala" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/18983-hill-harper-attends-international-centre-for-missing-and-exploited-children-gala">Hill Harper Attends International Centre for Missing and Exploited Children Gala</a>
<span class="date">May  8, 2019</span>
</h4>
The International Centre for Missing and Exploited Children&#8217;s Gala inspired partners and funders who share the collective purpose of eradicating child sexual abuse/exploitation and finding missing children.
<a href="/news/18983-hill-harper-attends-international-centre-for-missing-and-exploited-children-gala" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>

</section>
<section><ul class="headlines">
<li>
<h4>
<a href="https://www.looktothestars.org/news/18418-campaign-for-black-male-achievements-10th-anniversary-gala-honors-george-soros">Campaign for Black Male Achievement's 10th Anniversary Gala Honors George Soros</a>
<span class="date">Oct 17, 2018</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/15599-stars-attend-ny-celebration-of-7th-annual-kiehls-liferide">Stars Attend NY Celebration Of 7th Annual Kiehl’s LifeRide</a>
<span class="date">Aug  8, 2016</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/15573-kiehls-national-liferide-for-amfar-celebrates-at-nyc-flagship-store">Kiehl’s National LifeRide For amfAR Celebrates At NYC Flagship Store</a>
<span class="date">Aug  1, 2016</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/15382-melky-jean-presents-9th-annual-geminis-give-back">Melky Jean Presents 9th Annual Geminis Give Back</a>
<span class="date">Jun 10, 2016</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/14256-stars-join-rally-for-kids-with-cancer-scavenger-cup">Stars Join Rally For Kids With Cancer Scavenger Cup</a>
<span class="date">Sep 17, 2015</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/13100-la-art-show-to-benefit-st-jude-childrens-research-hospital">LA Art Show To Benefit St. Jude Children's Research Hospital</a>
<span class="date">Jan  9, 2015</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/12355-annalynne-mccord-and-corey-feldman-help-mark-world-day-against-human-trafficking">AnnaLynne McCord And Corey Feldman Help Mark World Day Against Human Trafficking</a>
<span class="date">Jul 28, 2014</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/12024-the-game-joins-stars-at-bresee-youth-film-festival">The Game Joins Stars At Bresee Youth Film Festival</a>
<span class="date">May 20, 2014</span>
</h4>
</li>
</ul>
</section>

<a href="/celebrity/hill-harper/news" class="more">More news about Hill Harper <span class="arrow">&rarr;</span></a>
</section>

<section id="related-videos">
<a name="related-videos"></a>
<h3>
Related videos
<span class="badge">1</span>
</h3>
<div class="row">
<div class="col-md-6"><div class="media video">
<div class="media-left">
<a href="https://www.looktothestars.org/video/377-hill-harper-talks-about-getting-tested"><div class="thumbnail video"><span class="video-thumb-container"><span class="wrap"><span class="shim"></span><img alt="Hill Harper Talks About Getting Tested" class="video thumb" height="90" src="https://i4.ytimg.com/vi/_N1NibOYqhU/default.jpg" width="120" /></span><span class="play">Play</span></span></div></a>
</div>
<div class="media-body">
<h5 class="media-heading"><a href="https://www.looktothestars.org/video/377-hill-harper-talks-about-getting-tested">Hill Harper Talks About Getting Tested</a></h5>
</div>
</div>

</div>
<div class="col-md-6">
</div>
</div>

</section>


<section id="web-sites">
<h4>Official web sites</h4>
<p>No web sites are known</p>
</section>
<section id="fields">
<h4>Browse celebrities in the same fields</h4>
<p class="item-links">
<a href="https://www.looktothestars.org/field/television">Television</a>, <a href="https://www.looktothestars.org/field/movies">Movies</a></p>
<a href="/field" class="more">More fields <span class="arrow">&rarr;</span></a>
</section>

</main>
<aside class="col-md-4 col-xs-12">
<div id="sidebar">

<section class="ad">
<div class="wrapper adsense">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2433408764489440"
     data-ad-slot="2987156042"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</section>

<section>
<h3><a href="/celebrity">Top celebrities</a></h3>
<ul class="top-thumbs">
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/elton-john" class="image-link"><img alt="Elton John" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/6341-elton-john/small_square-1503121378.jpg" title="Elton John" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/elton-john">Elton John</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/bill-clinton" class="image-link"><img alt="Bill Clinton" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/24-bill-clinton/small_square-1503121377.jpg" title="Bill Clinton" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/bill-clinton">Bill Clinton</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/sting" class="image-link"><img alt="Sting" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/134-sting/small_square-1503121378.jpg" title="Sting" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/sting">Sting</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/annie-lennox" class="image-link"><img alt="Annie Lennox" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/2984-annie-lennox/small_square-1503121378.jpg" title="Annie Lennox" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/annie-lennox">Annie Lennox</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/paul-mccartney" class="image-link"><img alt="Paul McCartney" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/7581-paul-mccartney/small_square-1503121378.jpg" title="Paul McCartney" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/paul-mccartney">Paul McCartney</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/bono" class="image-link"><img alt="Bono" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/9-bono/small_square-1503121378.jpg" title="Bono" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/bono">Bono</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/lady-gaga" class="image-link"><img alt="Lady Gaga" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/11572-lady-gaga/small_square-1503620652.jpg" title="Lady Gaga" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/lady-gaga">Lady Gaga</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/george-clooney" class="image-link"><img alt="George Clooney" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/3-george-clooney/small_square-1503121378.jpg" title="George Clooney" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/george-clooney">George Clooney</a></div>
</div>
</div>
</li>
</ul>
<a href="/celebrity" class="more">More celebrities <span class="arrow">&rarr;</span></a>
</section>
<section>
<h3><a href="/charity">Top charities</a></h3>
<ul class="top-thumbs">
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/unicef" class="image-link"><img alt="UNICEF" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/7146-unicef/small_square-1503121378.jpg" title="UNICEF" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/unicef">UNICEF</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/peta" class="image-link"><img alt="PETA" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1242-peta/small_square-1503121378.jpg" title="PETA" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/peta">PETA</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/elton-john-aids-foundation" class="image-link"><img alt="Elton John AIDS Foundation" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/6908-elton-john-aids-foundation/small_square-1503121378.jpg" title="Elton John AIDS Foundation" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/elton-john-aids-foundation">Elton John AIDS Foundation</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/red-cross" class="image-link"><img alt="Red Cross" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1295-red-cross/small_square-1503121378.jpg" title="Red Cross" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/red-cross">Red Cross</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/save-the-children" class="image-link"><img alt="Save the Children" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1251-save-the-children/small_square-1503121378.jpg" title="Save the Children" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/save-the-children">Save the Children</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/boys-and-girls-clubs-of-america" class="image-link"><img alt="Boys & Girls Clubs of America" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1259-boys-and-girls-clubs-of-america/small_square-1503129220.jpg" title="Boys & Girls Clubs of America" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/boys-and-girls-clubs-of-america">Boys & Girls Clubs of America</a></div>
</div>
</div>
</li>
</ul>
<a href="/charity" class="more">More charities <span class="arrow">&rarr;</span></a>
</section>

<section>
<h3><a href="/cause">Top causes</a></h3>
<p class="link-cloud"><span style="font-size:84%"><a href="https://www.looktothestars.org/cause/aids-and-hiv">AIDS & HIV</a></span>&emsp;
<span style="font-size:86%"><a href="https://www.looktothestars.org/cause/animals">Animals</a></span>&emsp;
<span style="font-size:99%"><a href="https://www.looktothestars.org/cause/at-risk-disadvantaged-youths">At-Risk/Disadvantaged Youths</a></span>&emsp;
<span style="font-size:90%"><a href="https://www.looktothestars.org/cause/cancer">Cancer</a></span>&emsp;
<span style="font-size:144%"><a href="https://www.looktothestars.org/cause/children">Children</a></span>&emsp;
<span style="font-size:105%"><a href="https://www.looktothestars.org/cause/education">Education</a></span>&emsp;
<span style="font-size:89%"><a href="https://www.looktothestars.org/cause/environment">Environment</a></span>&emsp;
<span style="font-size:128%"><a href="https://www.looktothestars.org/cause/health">Health</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/cause/human-rights">Human Rights</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/cause/miscellaneous">Miscellaneous</a></span>&emsp;
<span style="font-size:92%"><a href="https://www.looktothestars.org/cause/poverty">Poverty</a></span>&emsp;
<span style="font-size:85%"><a href="https://www.looktothestars.org/cause/women">Women</a></span></p>
<a href="/cause" class="more">More causes <span class="arrow">&rarr;</span></a>
</section>

<section class="ad">
<div class="wrapper adsense">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive sidebar secondary -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2433408764489440"
     data-ad-slot="4463889242"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</section>

<section class="latest-news">
<h3>Latest headlines</h3>
<ul class="item-links"><li><a href="https://www.looktothestars.org/news/20307-roger-daltrey-introduces-the-real-me-podcast-from-pantheon-and-teen-cancer-america">Roger Daltrey Introduces "The Real Me" Podcast From Pantheon and Teen Cancer America</a></li><li><a href="https://www.looktothestars.org/news/20302-victorias-secret-launches-initiative-with-stella-mccartney-to-reinforce-urgent-need-for-greater-awareness-of-breast-health">Victoria's Secret Launches Initiative with Stella McCartney to Reinforce Urgent Need for Greater Awareness of Breast Health</a></li><li><a href="https://www.looktothestars.org/news/20304-audacy-to-host-eighth-annual-we-can-survive-concert-at-the-iconic-hollywood-bowl">Audacy to Host Eighth Annual “We Can Survive” Concert at the Iconic Hollywood Bowl</a></li><li><a href="https://www.looktothestars.org/news/20301-john-legend-announces-bold-new-initiative-to-build-communities-that-work-for-all">John Legend Announces Bold, New Initiative To Build Communities That Work For All</a></li><li><a href="https://www.looktothestars.org/news/20306-chris-pratt-and-katherine-schwarzenegger-named-newest-special-olympics-global-ambassadors">Chris Pratt and Katherine Schwarzenegger Named Newest Special Olympics Global Ambassadors</a></li><li><a href="https://www.looktothestars.org/news/20300-women-in-film-announces-jane-fonda-and-zazie-beetz-among-2021-honorees">Women In Film Announces Jane Fonda & Zazie Beetz Among 2021 Honorees</a></li><li><a href="https://www.looktothestars.org/news/20303-city-of-hope-and-rwquarantunes-hosted-the-star-studded-16th-annual-songs-of-hope">City of Hope and RWQuarantunes Hosted the Star-Studded 16th Annual Songs of Hope</a></li><li><a href="https://www.looktothestars.org/news/20298-bruce-springsteen-to-perform-at-the-15th-annual-stand-up-for-heroes">Bruce Springsteen to Perform at the 15th Annual STAND UP FOR HEROES</a></li></ul>
</section>

<section class="ad">
<div class="wrapper">
<a href="/subscriptions/new"><img alt="Insider access to the industry&#x27;s most reliable celebrity/charity data" height="250" src="/images/banners/subscriptions-300x250-1632833073.jpg" width="300" /></a>
</div>
</section>

</div>
</aside>
</div>
</div>
<footer>
<div class="full">
<div class="container">
<div class="row">
<div class="col-sm-4">
<h4>About</h4>
<ul>
<li><a href="/about">About the site</a></li>
<li><a href="/about">Our team</a></li>
<li><a href="/advertising">Advertise here</a></li>
<li><a href="/contact">Contact us</a></li>
<li><a href="/subscriptions">Subscriptions</a></li>
<li><a href="/scams">Scam warning</a></li>
</ul>
</div>
<div class="col-sm-6">
<h4>Follow us</h4>
<div class="subscribe-buttons">
<a data-placement="bottom" data-toggle="tooltip" href="https://www.looktothestars.org/feed/rss20.xml" title="Subscribe to our feed">
<i class="fa fa-rss "></i>
<span class="sr-only">RSS feed</span>
</a>
<a class="list-subscribe-show" data-placement="bottom" data-toggle="tooltip" href="#" title="Get our news by email">
<i class="fa fa-envelope-o "></i>
<span class="sr-only">Mailing list</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://twitter.com/looktothestars" rel="nofollow" target="_new" title="Follow us on Twitter">
<i class="fa fa-twitter "></i>
<span class="sr-only">Twitter</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://www.facebook.com/pages/LookToTheStarsorg/43203819581" rel="nofollow" target="_new" title="Follow us on Facebook">
<i class="fa fa-facebook "></i>
<span class="sr-only">Facebook</span>
</a>
</div>

<h4>Legal</h4>
<ul>
<li><a href="/privacy">Privacy &amp; Cookie Policy</a></li>
<li><a href="/terms_of_use">Terms of Use</a></li>
<li><a href="/terms_and_conditions">Subscription Terms</a></li>
</ul>
</div>
<div class="col-sm-2">
<img alt="Footer-logo-1632833073" class="logo" src="/images/footer-logo-1632833073.svg" />
</div>
</div>
</div>
</div>
<div id="copyright">
<div class="full">
<div class="container">
Copyright &copy; 2006-2021 Look To The Stars. All rights reserved.
</div>
</div>
</div>
</footer>
<div id="tip">&nbsp;</div>
<div aria-hidden="true" aria-labelledby="list_subscription_modal_title" class="modal fade" id="list_subscription_modal" role="dialog" tabindex="-1">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-header">
<button class="close" data-dismiss="modal" type="button">
<span aria-hidden="true">&times;</span>
<span class="sr-only">Close</span>
</button>
<h3 class="modal-title" id="list_subscription_modal_title">Get our news delivered straight to your Inbox, for free!</h3>
</div>
<div class="modal-body">
<div id="list_subscriptions_form">
<form accept-charset="UTF-8" action="/list_subscriptions" class="new_list_subscription" data-remote="true" id="new_list_subscription" method="post"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /><input name="authenticity_token" type="hidden" value="fIxU66W7JkT/zgD51tVCj7AZOFD2XaTSQcaT6WLrmiE=" /></div><div class="clearfix"></div>
<div class="form-group">
<label class="sr-only" for="list_subscription_email">Your email address:</label>
<input class="form-control" id="list_subscription_email" name="list_subscription[email]" placeholder="Your email address" required="required" size="30" type="email" />
</div>
<div class="form-group">
<input class="btn btn-primary" data-disable-with="Saving..." name="commit" type="submit" value="Subscribe now" />
<button class="btn btn-default" data-dismiss="modal" type="button">No thanks</button>
</div>
</form>

</div>

</div>
</div>
</div>
</div>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-67727-2', 'looktothestars.org');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');
</script>

<script data-main="/javascripts/all-1632833386.js" src="/javascripts/vendor/require-1632833365.js"></script>
</body>
</html>
