<!DOCTYPE html>
<html class="prime" lang="en">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video#">
<meta charset="utf-8">
<meta content="Roger Daltrey, celebrity, charity, news" lang="en" name="keywords">
<meta content="Profile of Roger Daltrey&#x27;s support for charities including Live 8, PETA, and Teenage Cancer Trust. We have 59 articles about Roger Daltrey&#x27;s philanthropy. " lang="en" name="description">
<meta content="index" name="robots">
<meta content="width=device-width, initial-scale=1.0" name="viewport">
<link href="/images/apple-touch-icon-144-precomposed-1615785030.png" rel="apple-touch-icon-precomposed" sizes="144x144">
<link href="/images/apple-touch-icon-114-precomposed-1615785030.png" rel="apple-touch-icon-precomposed" sizes="114x114">
<link href="/images/apple-touch-icon-72-precomposed-1615785030.png" rel="apple-touch-icon-precomposed" sizes="72x72">
<link href="/images/apple-touch-icon-57-precomposed-1615785030.png" rel="apple-touch-icon-precomposed" sizes="57x57">
<meta content="yes" name="apple-mobile-web-app-capable">
<meta content="yes" name="mobile-web-app-capable">
<meta content="black" name="apple-mobile-web-app-status-bar-style">
<link href="/images/favicon-1615785030.png" rel="icon">
<!--[if IE]>
<link href="/images/favicon-1615785030.png" rel="shortcut icon">
<![endif]-->
<meta content="IE=edge" http-equiv="X-UA-Compatible">
<meta content="/images/apple-touch-icon-144-precomposed-1615785030.png" name="msapplication-TileImage">
<meta content="#fee133" name="msapplication-TileColor">
<meta content="Look to the Stars" name="msapplication-tooltip">
<meta content="#fee133" name="msapplication-navbutton-color">
<meta content="/" name="msapplication-starturl">
<meta content="Look to the Stars" name="application-name">
<meta content="Look to the Stars" name="apple-mobile-web-app-title">
<meta content="@looktothestars" name="twitter:site">
<meta content="pk_live_idk4U6tpUXcAV1RMXtw3Rwsh" name="stripe-key">
<meta content="Look to the Stars" property="og:site_name">
<meta content="https://www.looktothestars.org/celebrity/roger-daltrey" property="og:url">
<meta content="Roger Daltrey: Charity Work &amp; Causes" property="og:title">
<meta content="Profile of Roger Daltrey's support for charities including Live 8, PETA, and Teenage Cancer Trust. We have 59 articles about Roger Daltrey's philanthropy. " property="og:description">
<meta content="summary" property="twitter:card">
<meta content="Roger Daltrey: Charity Work &amp; Causes" property="twitter:title">
<meta content="Profile of Roger Daltrey's support for charities including Live 8, PETA, and Teenage Cancer Trust. We have 59 articles about Roger Daltrey's philanthropy. " property="twitter:description">
<meta content="https://www.looktothestars.org/photo/1871-roger-daltrey/story_half_width.jpg" property="twitter:image">
<meta content="https://www.looktothestars.org/photo/1871-roger-daltrey/story_half_width.jpg" property="og:image">
<link href="https://www.looktothestars.org/celebrity/roger-daltrey" rel="canonical">
<title>Roger Daltrey: Charity Work &amp; Causes - Look to the Stars</title>
<link href="/stylesheets/all-1615785254.css" media="screen" rel="stylesheet" type="text/css" />
<script>
  var username=null;
  window._$ = function(f) { window._$.backlog.unshift(f); };
  window._$.backlog = [];
</script>

<link href="https://www.looktothestars.org/feed/rss20.xml" rel="alternate" title="Latest Celebrity Charity News Items" type="application/rss+xml" />
<link href="https://www.looktothestars.org/celebrity/roger-daltrey/rss20.xml" rel="alternate" title="Latest Charity News About Roger Daltrey" type="application/rss+xml" />
</head>
<body>
<nav class="navbar navbar-fixed-top navbar-inverse" role="navigation">
<div class="container-fluid">
<div class="navbar-header">
<button class="navbar-toggle" data-target=".navbar-sections-collapse" data-toggle="collapse" type="button">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a class="visible-xs visible-sm navbar-brand" href="/">
Look to the Stars
</a>
</div>
<div class="collapse navbar-collapse navbar-sections-collapse">
<ul class="nav navbar-nav hidden-sm">
<li>
<a class="hidden-sm hidden-xs" href="/">Look to the Stars</a>
</li>
</ul>
<div class="navbar-form navbar-left"><form accept-charset="UTF-8" action="https://www.looktothestars.org/search" class="search" method="get" role="search"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /></div>
<div class="form-group">
<input accesskey="s" autocomplete="off" class="form-control typeahead search-query" name="query" placeholder="Search celebs/causes" required spellcheck="off" type="search">
<input style="visibility: hidden; position: fixed;" type="submit">
</div>
</form>

</div>
<div class="navbar-left navbar-text hidden-xs hidden-sm"><div class="subscribe-buttons">
<a data-placement="bottom" data-toggle="tooltip" href="https://www.looktothestars.org/feed/rss20.xml" title="Subscribe to our feed">
<i class="fa fa-rss "></i>
<span class="sr-only">RSS feed</span>
</a>
<a class="list-subscribe-show" data-placement="bottom" data-toggle="tooltip" href="#" title="Get our news by email">
<i class="fa fa-envelope-o "></i>
<span class="sr-only">Mailing list</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://twitter.com/looktothestars" rel="nofollow" target="_new" title="Follow us on Twitter">
<i class="fa fa-twitter "></i>
<span class="sr-only">Twitter</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://www.facebook.com/pages/LookToTheStarsorg/43203819581" rel="nofollow" target="_new" title="Follow us on Facebook">
<i class="fa fa-facebook "></i>
<span class="sr-only">Facebook</span>
</a>
</div>
</div>
<ul class="nav navbar-nav navbar-right">
<li class="subscribe"><a href="/subscriptions" data-placement="bottom" data-toggle="tooltip" title="Find out about our subscriptions">Subscribe</a></li>
<li><a href="/users/sign_in">Sign in</a></li>
</ul>
<ul class="nav navbar-nav visible-sm visible-xs">
<li><a href="/celebrity" title="4639 celebrities supporting charities">Celebrities</a></li>
<li><a href="/charity" title="2390 charities with celebrity supporters">Charities</a></li>
<li><a href="/news" title="News about celebrities doing good">News</a></li>
<li><a href="/company" title="Companies with celebrity/charity interests">Companies</a></li>
<li><a href="/cause" title="Charitable areas of interest">Causes</a></li>
<li><a href="/calendar" title="Calendar of celebrity charity events">Calendar</a></li>
<li><a href="/about" title="Find out more about this website">About</a></li>

</ul>
</div>
</div>
</nav>
<div id="top"></div>
<nav class="navbar navbar-default hidden-sm hidden-xs" id="section-nav" role="navigation">
<div class="container-fluid">
<ul class="nav navbar-nav">
<li><a href="/celebrity" data-placement="bottom" data-toggle="tooltip" title="4639 celebrities supporting charities">Celebrities</a></li>
<li><a href="/charity" data-placement="bottom" data-toggle="tooltip" title="2390 charities with celebrity supporters">Charities</a></li>
<li><a href="/news" data-placement="bottom" data-toggle="tooltip" title="News about celebrities doing good">News</a></li>
<li><a href="/company" data-placement="bottom" data-toggle="tooltip" title="Companies with celebrity/charity interests">Companies</a></li>
<li><a href="/cause" data-placement="bottom" data-toggle="tooltip" title="Charitable areas of interest">Causes</a></li>
<li><a href="/calendar" data-placement="bottom" data-toggle="tooltip" title="Calendar of celebrity charity events">Calendar</a></li>
<li><a href="/about" data-placement="bottom" data-toggle="tooltip" title="Find out more about this website">About</a></li>

</ul>
</div>
</nav>
<div class="hidden-sm hidden-xs" id="masthead">
<div class="container">
<h4>
<a href="/">
<span class="sr-only">Look to the Stars - the world of celebrity giving</span>
</a>
</h4>
</div>
</div>
<div class="container" id="page" itemscope itemtype="http://schema.org/Person">
<div id="page-heading">
<ul class="breadcrumb">
<li><a href="/">Home</a></li>
<li><a href="/celebrity">Celebrities</a></li>
</ul>
<h1 class="page-header"><span itemprop="name">Roger Daltrey</span> <small>Charity Work, Events and Causes</small></h1>
</div>
<div class="row">
<main class="col-md-8" id="main" role="main">
<section id="celebrity">
<div class="media">
<div class="media-left">
<img alt="Roger Daltrey" class="photo thumbnail teaser " height="150" itemprop="image" src="https://www.looktothestars.org/photo/1871-roger-daltrey/teaser-1503125269.jpg" title="Roger Daltrey" width="150" />
</div>
<div class="media-body">
<div class="row">
<div class="col-xs-6">
<div class="key-numbers">
<a class="stat" href="#charities">
<div class="num">12</div>
charities
</a>
<a class="stat" href="#causes">
<div class="num">14</div>
causes
</a>
</div>
</div>
<div class="col-xs-6">
<div class="key-numbers">
<a class="stat" href="#related-news">
<div class="num">59</div>
articles
</a>
<a class="stat" href="#related-videos">
<div class="num">0</div>
videos
</a>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="truncate" id="celebrity-bio">
<div>
<div itemprop="description"><p>Roger Daltrey is the lead singer of <a href="https://www.looktothestars.org/celebrity/the-who">The Who</a>, and is Patron of the <a href="https://www.looktothestars.org/charity/teenage-cancer-trust">Teenage Cancer Trust</a>.</p>
<p>He sang &#8220;Rock and Roll&#8221; on a charity single released as <em>McEnroe &amp; Cash with The Full Metal Rackets</em> for Rock Aid Armenia in 1986.</p>
<p>He performed with The Who at Live Aid in 1985 and Concert for Kampuchea in 1979.</p>
<p>In 1976, he performed at the Celtic Football Ground in Glasgow, Scotland, with proceeds of over £100,000 donated to charity.</p>
<p>He performed for the <a href="https://www.looktothestars.org/charity/robin-hood">Robin Hood</a> Foundation at the The Concert for New York City and other benefits in 2001; at Neil Young&#8217;s <a href="https://www.looktothestars.org/charity/bridge-school">Bridge School</a> Benefit in 1999; and in the Quadrophenia Concert for The <a href="https://www.looktothestars.org/charity/princes-trust">Prince&#x27;s Trust</a> in Hyde Park in 1996.</p>
<p>He attended a <a href="https://www.looktothestars.org/charity/peta">PETA</a> benefit with <a href="https://www.looktothestars.org/celebrity/sarah-mclachlan">Sarah McLachlan</a> and <a href="https://www.looktothestars.org/celebrity/chrissie-hynde">Chrissie Hynde</a>.</p>
<p>He appeared in <em>The Wizard of Oz in Concert: Dreams Come True</em> in 1995 for the <a href="https://www.looktothestars.org/charity/childrens-defense-fund">Children&#x27;s Defense Fund</a>, and at the Freddie Mercury Tribute Concert to benefit <span class="caps">AIDS</span> research in 1992.</p></div>
<p class="copyright">
Copyright &copy; 2021 Look to the Stars, All rights reserved.
</p>
</div>
</section>
<section id="charity-connections">
<div id="supported-charities">
<a name="charities"></a>
<h3>
Charities &amp; foundations supported
<span class="badge">12</span>
</h3>
<p class="muted">
Roger Daltrey has supported the following charities listed on this site:
</p>
<div class="row">
<div class="col-sm-6"><ul class="item-links"><li><a href="https://www.looktothestars.org/charity/bridge-school">Bridge School</a></li><li><a href="https://www.looktothestars.org/charity/killing-cancer">Killing Cancer</a></li><li><a href="https://www.looktothestars.org/charity/live-8">Live 8</a></li><li><a href="https://www.looktothestars.org/charity/macmillan-cancer-support">Macmillan Cancer Support</a></li><li><a href="https://www.looktothestars.org/charity/nordoff-robbins">Nordoff Robbins</a></li><li><a href="https://www.looktothestars.org/charity/norwood">Norwood</a></li></ul></div>
<div class="col-sm-6"><ul class="item-links"><li><a href="https://www.looktothestars.org/charity/peta">PETA</a></li><li><a href="https://www.looktothestars.org/charity/princes-trust">Prince's Trust</a></li><li><a href="https://www.looktothestars.org/charity/robin-hood">Robin Hood</a></li><li><a href="https://www.looktothestars.org/charity/teenage-cancer-trust">Teenage Cancer Trust</a></li><li><a href="https://www.looktothestars.org/charity/teen-cancer-america">Teen Cancer America</a></li><li><a href="https://www.looktothestars.org/charity/willow-foundation">Willow Foundation</a></li></ul></div>
</div>
<aside>
<p class="small muted">
Did we miss something?
<a href="/contact?about=error">Let us know!</a>
</p>
</aside>
</div>
<div class="row">
<div class="col-md-5 col-lg-6">
<div class="panel panel-default panel-similar">
<div class="panel-heading">
<h4>Other supporters of the same charities & foundations</h4>
</div>
<div class="panel-body">
<p class="link-cloud"><span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/annie-lennox">Annie Lennox</a></span>&emsp;
<span style="font-size:96%"><a href="https://www.looktothestars.org/celebrity/brian-may">Brian May</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/bryan-adams">Bryan Adams</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/eddie-vedder">Eddie Vedder</a></span>&emsp;
<span style="font-size:96%"><a href="https://www.looktothestars.org/celebrity/eric-clapton">Eric Clapton</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/jamie-cullum">Jamie Cullum</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/joanna-lumley">Joanna Lumley</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/joss-stone">Joss Stone</a></span>&emsp;
<span style="font-size:108%"><a href="https://www.looktothestars.org/celebrity/paul-mccartney">Paul McCartney</a></span>&emsp;
<span style="font-size:96%"><a href="https://www.looktothestars.org/celebrity/pete-townshend">Pete Townshend</a></span>&emsp;
<span style="font-size:96%"><a href="https://www.looktothestars.org/celebrity/ricky-gervais">Ricky Gervais</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/robert-plant">Robert Plant</a></span>&emsp;
<span style="font-size:144%"><a href="https://www.looktothestars.org/celebrity/sting">Sting</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/the-who">The Who</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/celebrity/tom-jones">Tom Jones</a></span></p>
</div>
</div>
</div>
<div class="col-md-7 col-lg-6">
<div class="insights-hidden panel panel-insights">
<div class="panel-heading">
<h4>
Insights
</h4>
</div>
<div class="panel-body">
<div class="key-numbers">
<div class="stat">
<div class="num">
<span data-toggle="tooltip" title="Available to Insider Access subscribers only"><i class="fa fa-lock "></i></span>
</div>
Activity
<span class="what-is-this" data-placement="bottom" data-toggle="tooltip" title="Number from 0 to 100 indicating relative level of charitable activity"><i class="fa fa-question-circle "></i></span>
</div>
<div class="stat">
<div class="num">
<span data-toggle="tooltip" title="Available to Insider Access subscribers only"><i class="fa fa-lock "></i></span>
</div>
Social reach
<span class="what-is-this" data-placement="bottom" data-toggle="tooltip" title="Number from 0 to 100 indicating relative level of social media following"><i class="fa fa-question-circle "></i></span>
</div>
</div>
<p data-toggle="tooltip" title="Available to subscribers only">
<i class="fa fa-globe "></i>
<span class="num">1</span>
related place
</p>
<div class="google-trends">
<i class="fa fa-line-chart "></i>
<a class="show-chart" href="#">Google trends for "Roger Daltrey"</a>
<div class="chart">
Available to Insiders only
</div>
</div>
</div>
<div class="panel-footer">
<a class="small" href="/subscriptions/new">
<strong>Get Insider Access</strong> to these insights & more...
</a>
</div>
</div>

</div>
</div>
</section>
<section id="supported-causes">
<a name="causes"></a>
<h3>
Causes supported
<span class="badge">14</span>
</h3>
<p class="item-links">
<a href="https://www.looktothestars.org/cause/adoption-fostering-orphans">Adoption, Fostering, Orphans</a>, <a href="https://www.looktothestars.org/cause/aids-and-hiv">AIDS & HIV</a>, <a href="https://www.looktothestars.org/cause/animals">Animals</a>, <a href="https://www.looktothestars.org/cause/at-risk-disadvantaged-youths">At-Risk/Disadvantaged Youths</a>, <a href="https://www.looktothestars.org/cause/cancer">Cancer</a>, <a href="https://www.looktothestars.org/cause/children">Children</a>, <a href="https://www.looktothestars.org/cause/economic-business-support">Economic/Business Support</a>, <a href="https://www.looktothestars.org/cause/education">Education</a>, <a href="https://www.looktothestars.org/cause/health">Health</a>, <a href="https://www.looktothestars.org/cause/literacy">Literacy</a>, <a href="https://www.looktothestars.org/cause/mental-challenges">Mental Challenges</a>, <a href="https://www.looktothestars.org/cause/miscellaneous">Miscellaneous</a>, <a href="https://www.looktothestars.org/cause/physical-challenges">Physical Challenges</a>, <a href="https://www.looktothestars.org/cause/poverty">Poverty</a></p>
<a name="contact"></a>
<div class="panel panel-default panel-contact-celeb" id="contact-celeb">
<div class="panel-heading">
<h4>Contact Roger Daltrey</h4>
</div>
<div class="panel-body">
<p>
You can contact Roger Daltrey using details from <strong><a href="https://contactanycelebrity.com/idevaffiliate/idevaffiliate.php?id=101" class="contact-service" rel="nofollow">this service</a></strong>.
(Or read our <a href="https://www.looktothestars.org/how_to_contact_celebrities">advice on how to contact celebrities</a>)
</p>
</div>
</div>
</section>
<section id="related-news">
<a name="related-news"></a>
<h3>
<a href="/celebrity/roger-daltrey/news">Related charity news and events <span class="badge">59</span></a>
</h3>
<section><section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/19278-we-are-family-foundation-to-honor-dolly-parton-and-jean-paul-gaultier"><img alt="We Are Family Foundation To Honor Dolly Parton And Jean Paul Gaultier" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/528-dolly-parton/teaser-1503133515.jpg" title="We Are Family Foundation To Honor Dolly Parton And Jean Paul Gaultier" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/19278-we-are-family-foundation-to-honor-dolly-parton-and-jean-paul-gaultier">We Are Family Foundation To Honor Dolly Parton And Jean Paul Gaultier</a>
<span class="date">Sep 12, 2019</span>
</h4>
We Are Family Foundation (WAFF) will honor legendary artist Dolly Parton and iconic fashion designer Jean Paul Gaultier at its 2019 Celebration on Tuesday, November 5, 2019 at the Hammerstein Ballroom in New York City.
<a href="/news/19278-we-are-family-foundation-to-honor-dolly-parton-and-jean-paul-gaultier" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>
<section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/19054-the-second-annual-monster-energy-50k-charity-challenge-celebrity-basketball-game"><img alt="The Second Annual Monster Energy $50K Charity Challenge Celebrity Basketball Game" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/1871-roger-daltrey/teaser-1503125269.jpg" title="The Second Annual Monster Energy $50K Charity Challenge Celebrity Basketball Game" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/19054-the-second-annual-monster-energy-50k-charity-challenge-celebrity-basketball-game">The Second Annual Monster Energy $50K Charity Challenge Celebrity Basketball Game</a>
<span class="date">Jun  3, 2019</span>
</h4>
For sports fans and celebrity watchers alike, the second annual Monster Energy $50K Charity Challenge Celebrity Basketball Game will return to UCLA&#8217;s Pauley Pavilion on Monday, July 8 to celebrate the 2019 ESPY Awards Week.
<a href="/news/19054-the-second-annual-monster-energy-50k-charity-challenge-celebrity-basketball-game" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>
<section>
<div class="media news-teaser">
<div class="media-left"><a href="/news/18674-the-who-announce-2019-north-american-moving-on-tour"><img alt="The Who Announce 2019 North American MOVING ON! TOUR" class="photo thumbnail teaser " height="150" src="https://www.looktothestars.org/photo/240-the-who/teaser-1503133129.jpg" title="The Who Announce 2019 North American MOVING ON! TOUR" width="150" /></a></div>
<div class="media-body">
<h4 class="media-heading">
<a href="https://www.looktothestars.org/news/18674-the-who-announce-2019-north-american-moving-on-tour">The Who Announce 2019 North American MOVING ON! TOUR</a>
<span class="date">Jan 22, 2019</span>
</h4>
For The Who fans everywhere, the announcement of a brand new tour means only one thing: the world&#8217;s most untameable rock band is about to deliver the goods once again.
<a href="/news/18674-the-who-announce-2019-north-american-moving-on-tour" class="more">More <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>

</section>
<section><ul class="headlines">
<li>
<h4>
<a href="https://www.looktothestars.org/news/18224-don-mclean-joins-ed-sheeran-roger-daltrey-van-morrison-for-charity-fundraiser">Don McLean Joins Ed Sheeran, Roger Daltrey, Van Morrison For Charity Fundraiser</a>
<span class="date">Aug 22, 2018</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/18201-ed-sheeran-van-morrison-to-join-roger-daltrey-and-friends-in-epic-charity-concert-and-auction">Ed Sheeran, Van Morrison to Join Roger Daltrey and Friends in Epic Charity Concert and Auction</a>
<span class="date">Aug 14, 2018</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/17823-parkland-teens-to-speak-at-we-are-family-foundation-2018-celebration-gala">Parkland Teens To Speak At We Are Family Foundation 2018 Celebration Gala</a>
<span class="date">Apr 19, 2018</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/17722-we-are-family-foundation-to-honor-roger-daltrey-cbe-and-ll-cool-j">We Are Family Foundation To Honor Roger Daltrey CBE And LL COOL J</a>
<span class="date">Mar 21, 2018</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/16087-grammy-foundation-and-musicares-announce-giving-tuesday-online-auction">GRAMMY Foundation and MusiCares Announce Giving Tuesday Online Auction</a>
<span class="date">Dec  2, 2016</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/16070-roger-daltrey-honored-with-music-industry-trusts-award">Roger Daltrey Honored With Music Industry Trusts Award</a>
<span class="date">Nov 29, 2016</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/16031-roger-daltrey-performs-at-19th-annual-collaborating-for-a-cure-benefit-dinner-and-auction">Roger Daltrey Performs At 19th Annual Collaborating For A Cure Benefit Dinner And Auction</a>
<span class="date">Nov 21, 2016</span>
</h4>
</li>
<li>
<h4>
<a href="https://www.looktothestars.org/news/16026-stars-pose-for-2017-hear-the-world-calendar">Stars Pose For 2017 Hear The World Calendar</a>
<span class="date">Nov 17, 2016</span>
</h4>
</li>
</ul>
</section>

<a href="/celebrity/roger-daltrey/news" class="more">More news about Roger Daltrey <span class="arrow">&rarr;</span></a>
</section>

<section id="related-videos">
<a name="related-videos"></a>
<h3>
Related videos

</h3>
<p>We don't have any videos related to Roger Daltrey.</p>
</section>

<section id="related-products">
<h3>Related products</h3>
<section class="product">
<div class="media">
<div class="media-left">
<a href="http://www.amazon.com/Love-Music-Food-Rock-Cookbook/dp/1844009947/?tag=looktothestar-20" rel="nofollow"><img alt="Love Music Love Food - The Rockstar Cookbook" class="photo thumbnail thumbnail " height="130" src="https://www.looktothestars.org/photo/5426-love-music-love-food-the-rockstar-cookbook/thumbnail-1503144797.jpg" title="Love Music Love Food - The Rockstar Cookbook" width="128" /></a>
</div>
<div class="media-body">
<h4 class="media-heading">
<a href="http://www.amazon.com/Love-Music-Food-Rock-Cookbook/dp/1844009947/?tag=looktothestar-20" rel="nofollow">Love Music Love Food - The Rockstar Cookbook</a>

</h4>
<p>This collection of portraits has been created in the name of Teenage Cancer Trust and predominantly features those artists who have supported the charity over the years, whether taking part in the annual Royal Albert Hall shows, visiting wards, donating a multitude of gifts from signed amps to signed sunglasses or getting involved in projects such as Love Music Love Food.</p>
<a href="http://www.amazon.com/Love-Music-Food-Rock-Cookbook/dp/1844009947/?tag=looktothestar-20" class="more" rel="nofollow">Find out more <span class="arrow">&rarr;</span></a>
</div>
</div>
</section>

</section>

<section id="web-sites">
<h4>Official web sites</h4>
<ul>
<li>
<a href="http://www.thewho.com/" class="web-site web-site-default " itemprop="url">Official Site</a>
</li>
</ul>

</section>
<section id="fields">
<h4>Browse celebrities in the same fields</h4>
<p class="item-links">
<a href="https://www.looktothestars.org/field/movies">Movies</a>, <a href="https://www.looktothestars.org/field/music">Music</a></p>
<a href="/field" class="more">More fields <span class="arrow">&rarr;</span></a>
</section>

</main>
<aside class="col-md-4 col-xs-12">
<div id="sidebar">

<section class="ad">
<div class="wrapper adsense">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2433408764489440"
     data-ad-slot="2987156042"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</section>

<section>
<h3><a href="/celebrity">Top celebrities</a></h3>
<ul class="top-thumbs">
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/elton-john" class="image-link"><img alt="Elton John" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/6341-elton-john/small_square-1503121378.jpg" title="Elton John" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/elton-john">Elton John</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/bill-clinton" class="image-link"><img alt="Bill Clinton" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/24-bill-clinton/small_square-1503121377.jpg" title="Bill Clinton" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/bill-clinton">Bill Clinton</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/sting" class="image-link"><img alt="Sting" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/134-sting/small_square-1503121378.jpg" title="Sting" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/sting">Sting</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/annie-lennox" class="image-link"><img alt="Annie Lennox" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/2984-annie-lennox/small_square-1503121378.jpg" title="Annie Lennox" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/annie-lennox">Annie Lennox</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/paul-mccartney" class="image-link"><img alt="Paul McCartney" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/7581-paul-mccartney/small_square-1503121378.jpg" title="Paul McCartney" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/paul-mccartney">Paul McCartney</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/bono" class="image-link"><img alt="Bono" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/9-bono/small_square-1503121378.jpg" title="Bono" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/bono">Bono</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/lady-gaga" class="image-link"><img alt="Lady Gaga" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/11572-lady-gaga/small_square-1503620652.jpg" title="Lady Gaga" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/lady-gaga">Lady Gaga</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/celebrity/george-clooney" class="image-link"><img alt="George Clooney" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/3-george-clooney/small_square-1503121378.jpg" title="George Clooney" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/celebrity/george-clooney">George Clooney</a></div>
</div>
</div>
</li>
</ul>
<a href="/celebrity" class="more">More celebrities <span class="arrow">&rarr;</span></a>
</section>
<section>
<h3><a href="/charity">Top charities</a></h3>
<ul class="top-thumbs">
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/unicef" class="image-link"><img alt="UNICEF" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/7146-unicef/small_square-1503121378.jpg" title="UNICEF" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/unicef">UNICEF</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/peta" class="image-link"><img alt="PETA" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1242-peta/small_square-1503121378.jpg" title="PETA" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/peta">PETA</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/elton-john-aids-foundation" class="image-link"><img alt="Elton John AIDS Foundation" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/6908-elton-john-aids-foundation/small_square-1503121378.jpg" title="Elton John AIDS Foundation" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/elton-john-aids-foundation">Elton John AIDS Foundation</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/red-cross" class="image-link"><img alt="Red Cross" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1295-red-cross/small_square-1503121378.jpg" title="Red Cross" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/red-cross">Red Cross</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/save-the-children" class="image-link"><img alt="Save the Children" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1251-save-the-children/small_square-1503121378.jpg" title="Save the Children" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/save-the-children">Save the Children</a></div>
</div>
</div>
</li>
<li>
<div class="media">
<div class="media-left">
<a href="https://www.looktothestars.org/charity/boys-and-girls-clubs-of-america" class="image-link"><img alt="Boys & Girls Clubs of America" class="photo thumbnail small_square " height="70" src="https://www.looktothestars.org/photo/1259-boys-and-girls-clubs-of-america/small_square-1503129220.jpg" title="Boys & Girls Clubs of America" width="70" /></a>
</div>
<div class="media-body">
<div class="media-heading"><a href="https://www.looktothestars.org/charity/boys-and-girls-clubs-of-america">Boys & Girls Clubs of America</a></div>
</div>
</div>
</li>
</ul>
<a href="/charity" class="more">More charities <span class="arrow">&rarr;</span></a>
</section>

<section>
<h3><a href="/cause">Top causes</a></h3>
<p class="link-cloud"><span style="font-size:84%"><a href="https://www.looktothestars.org/cause/aids-and-hiv">AIDS & HIV</a></span>&emsp;
<span style="font-size:86%"><a href="https://www.looktothestars.org/cause/animals">Animals</a></span>&emsp;
<span style="font-size:99%"><a href="https://www.looktothestars.org/cause/at-risk-disadvantaged-youths">At-Risk/Disadvantaged Youths</a></span>&emsp;
<span style="font-size:90%"><a href="https://www.looktothestars.org/cause/cancer">Cancer</a></span>&emsp;
<span style="font-size:144%"><a href="https://www.looktothestars.org/cause/children">Children</a></span>&emsp;
<span style="font-size:105%"><a href="https://www.looktothestars.org/cause/education">Education</a></span>&emsp;
<span style="font-size:89%"><a href="https://www.looktothestars.org/cause/environment">Environment</a></span>&emsp;
<span style="font-size:128%"><a href="https://www.looktothestars.org/cause/health">Health</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/cause/human-rights">Human Rights</a></span>&emsp;
<span style="font-size:84%"><a href="https://www.looktothestars.org/cause/miscellaneous">Miscellaneous</a></span>&emsp;
<span style="font-size:92%"><a href="https://www.looktothestars.org/cause/poverty">Poverty</a></span>&emsp;
<span style="font-size:85%"><a href="https://www.looktothestars.org/cause/women">Women</a></span></p>
<a href="/cause" class="more">More causes <span class="arrow">&rarr;</span></a>
</section>

<section class="ad">
<div class="wrapper adsense">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive sidebar secondary -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2433408764489440"
     data-ad-slot="4463889242"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</section>

<section class="latest-news">
<h3>Latest headlines</h3>
<ul class="item-links"><li><a href="https://www.looktothestars.org/news/20171-2021-night-of-covenant-house-stars-virtual-gala">2021 Night of Covenant House Stars Virtual Gala</a></li><li><a href="https://www.looktothestars.org/news/20170-mark-ruffalo-uzo-aduba-help-nami-nyc-kick-off-mental-health-awareness-month">Mark Ruffalo, Uzo Aduba Help NAMI-NYC Kick-Off Mental Health Awareness Month</a></li><li><a href="https://www.looktothestars.org/news/20169-chrissy-teigen-and-kris-jenners-safely-x-baby2baby-mothers-day-partnership">Chrissy Teigen and Kris Jenner’s Safely x Baby2Baby Mother’s Day Partnership</a></li><li><a href="https://www.looktothestars.org/news/20168-uso-kicks-off-11th-annual-t-shirt-campaign">USO Kicks Off 11th Annual T-Shirt Campaign</a></li><li><a href="https://www.looktothestars.org/news/20167-international-jazz-day-2021-concludes-with-spectacular-all-star-global-concert">International Jazz Day 2021 Concludes with Spectacular All-Star Global Concert</a></li><li><a href="https://www.looktothestars.org/news/20166-alicia-keys-and-the-class-unite-for-a-powerful-collaboration-to-promote-mental-wellbeing">Alicia Keys And The Class Unite For A Powerful Collaboration To Promote Mental Wellbeing</a></li><li><a href="https://www.looktothestars.org/news/20161-wellness-4-humanity-announces-cities-and-dates-for-spread-love-not-covid-event-series">Wellness 4 Humanity Announces Cities and Dates for Spread Love Not Covid Event Series</a></li><li><a href="https://www.looktothestars.org/news/20164-stars-attend-charmaine-blake-oscar-viewing-dinner-to-benefit-faber-ryan-youth-foundation">Stars Attend Charmaine Blake Oscar Viewing Dinner to Benefit Faber Ryan Youth Foundation</a></li></ul>
</section>

<section class="ad">
<div class="wrapper">
<a href="/subscriptions/new"><img alt="Insider access to the industry&#x27;s most reliable celebrity/charity data" height="250" src="/images/banners/subscriptions-300x250-1615785030.jpg" width="300" /></a>
</div>
</section>

</div>
</aside>
</div>
</div>
<footer>
<div class="full">
<div class="container">
<div class="row">
<div class="col-sm-4">
<h4>About</h4>
<ul>
<li><a href="/about">About the site</a></li>
<li><a href="/about">Our team</a></li>
<li><a href="/advertising">Advertise here</a></li>
<li><a href="/contact">Contact us</a></li>
<li><a href="/subscriptions">Subscriptions</a></li>
<li><a href="/scams">Scam warning</a></li>
</ul>
</div>
<div class="col-sm-6">
<h4>Follow us</h4>
<div class="subscribe-buttons">
<a data-placement="bottom" data-toggle="tooltip" href="https://www.looktothestars.org/feed/rss20.xml" title="Subscribe to our feed">
<i class="fa fa-rss "></i>
<span class="sr-only">RSS feed</span>
</a>
<a class="list-subscribe-show" data-placement="bottom" data-toggle="tooltip" href="#" title="Get our news by email">
<i class="fa fa-envelope-o "></i>
<span class="sr-only">Mailing list</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://twitter.com/looktothestars" rel="nofollow" target="_new" title="Follow us on Twitter">
<i class="fa fa-twitter "></i>
<span class="sr-only">Twitter</span>
</a>
<a data-placement="bottom" data-toggle="tooltip" href="http://www.facebook.com/pages/LookToTheStarsorg/43203819581" rel="nofollow" target="_new" title="Follow us on Facebook">
<i class="fa fa-facebook "></i>
<span class="sr-only">Facebook</span>
</a>
</div>

<h4>Legal</h4>
<ul>
<li><a href="/privacy">Privacy &amp; Cookie Policy</a></li>
<li><a href="/terms_of_use">Terms of Use</a></li>
<li><a href="/terms_and_conditions">Subscription Terms</a></li>
</ul>
</div>
<div class="col-sm-2">
<img alt="Footer-logo-1615785030" class="logo" src="/images/footer-logo-1615785030.svg" />
</div>
</div>
</div>
</div>
<div id="copyright">
<div class="full">
<div class="container">
Copyright &copy; 2006-2021 Look To The Stars. All rights reserved.
</div>
</div>
</div>
</footer>
<div id="tip">&nbsp;</div>
<div aria-hidden="true" aria-labelledby="list_subscription_modal_title" class="modal fade" id="list_subscription_modal" role="dialog" tabindex="-1">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-header">
<button class="close" data-dismiss="modal" type="button">
<span aria-hidden="true">&times;</span>
<span class="sr-only">Close</span>
</button>
<h3 class="modal-title" id="list_subscription_modal_title">Get our news delivered straight to your Inbox, for free!</h3>
</div>
<div class="modal-body">
<div id="list_subscriptions_form">
<form accept-charset="UTF-8" action="/list_subscriptions" class="new_list_subscription" data-remote="true" id="new_list_subscription" method="post"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /><input name="authenticity_token" type="hidden" value="nGZU+90moz6HsGKEMfU5VFs7drwZDy0uX0VeFBXUY3w=" /></div><div class="clearfix"></div>
<div class="form-group">
<label class="sr-only" for="list_subscription_email">Your email address:</label>
<input class="form-control" id="list_subscription_email" name="list_subscription[email]" placeholder="Your email address" required="required" size="30" type="email" />
</div>
<div class="form-group">
<input class="btn btn-primary" data-disable-with="Saving..." name="commit" type="submit" value="Subscribe now" />
<button class="btn btn-default" data-dismiss="modal" type="button">No thanks</button>
</div>
</form>

</div>

</div>
</div>
</div>
</div>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-67727-2', 'looktothestars.org');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');
</script>

<script data-main="/javascripts/all-1615785251.js" src="/javascripts/vendor/require-1615785229.js"></script>
</body>
</html>
